Kmod-rtc-sd2068 package missing for mifi 3.201

Just upgraded a mifi from 3.009 to 3.201 by flashing an image I made via the imagebuilder and kmod-rtc-sd2068 package appears to be missing, is it going to be made available for 3.201? If not, is there an equivalent package I should now be using?

I added to internal list for software packages.

Thanks Alzhao, could you please explain to me how I access it? As a test, I tried running

./gl_image -p mifi -e kmod-rtc-sd2068

on a fresh git clone of gl_imagebuilder and I get these errors:

  • opkg_install_cmd: Cannot install package kmod-rtc-sd2068.
    Makefile:154: recipe for target ‘package_install’ failed
    make[2]: *** [package_install] Error 255
    Makefile:112: recipe for target ‘_call_image’ failed
    make[1]: *** [_call_image] Error 2
    Makefile:207: recipe for target ‘image’ failed
    make: *** [image] Error 2

this module is still not in the current repo yet. So you cannot install.

Ok thank you, I’ll periodically check the repo to see when it is added, could you please tell me the URL of the repo I should be monitoring?

Is it possible to get a copy of this package that works on 3.201 directly from you @alzhao? I can install it on the mifi myself via opkg

I am sorry that I don’t have the ipk. This is a kernel module that has to compile with kernel.

Ok thank you, should I be watching for a new firmware release?

The internal request is still pending. I will push.