Koalasafe KS-150N: Which Gl-inet device?

Hi everyone,

Does anyone know which Gl-inet device the Koalasafe KS-150N is based on?
Koalasafe have shutdown and pushed out Open-wrt to the devices, but only if they were in use in February, which mine wasn’t.
Whatever firmware it was gives a wifi name with Gi at the start, so I’m confident it was a Gl-inet device.
Tried the Ar-150 open wrt firmware, which installs, but then won’t detect the WAN port.

Seems to be based on a AR9330 chip (though maybe that’s my reading of the logs)

Anyone know?

Think it’s the GL-AR150 / White - GL.iNet

Hi Zimo,

What makes you think that out of interest?
That’s the firmware I went with…but it’s not working properly.

More notes here;
"I’ve actually been playing around with a Koalasafe and trying to work out which firmware’s might work.

So, for starters, you can reset one and gain access (at least for the model I have, which is an KS-150N), by following Gl-inets’ instructions here;

I followed the instructions for the Gl-inet GL-AR150 (reasoning that the model numbering and the fact they look the same meant the Koalasafe was the same or similar hardware) and installed the Open-wrt firmware from here;


Which worked insofar as the Ks-150n router is now handing out an ip address to my pc.

What it’s not doing is detecting the WAN connection from my modem…it shows the port as disconnected. Problem!

Now, the Ks-150N running Open-wrt show itself as having an AR9330 in the system logs.

Whereas the Gl-AR150 is listed as having an AR9331.[OpenWrt Wiki] GL.iNet GL-AR150

So I think I’m close…but I’m going to try some firmwares for devices with an AR9330 like these and see if I get anywhere;

Let me know if anyone else gets it working, would love to know which firmware works properly on the Koalasafe Ks150n."

That’s from my reply on a reddit post!

Think the AR150 is an AR9331, rather than the Ar9330…though as I say, that might just be the logs.

It is AR150 but I am not sure if there is physical modification. Can you send a photo?

AR150 firmware should definitely works.

I’ve played around aa fair bit now - it’s definately having issues.
Seems to think there are 3 ports; 2 lan and one wan.
It connects the lan ok, but does not detect the wan.

I tried the firmware off the open-wrt page rather than the gl.inet. Same thing.

The annoygin thing is we know it works, as Koala safe released an open-wrt firmware. It would be infuriating if it had to be custom.

Here’s a good pc from the manual.Screen Shot 2021-10-29 at 00.25.29|468x500

Maybe try the latest GL firmware, rather than vanilla OpenWRT, for it? GL.iNet download center

Good idea.
Appreciate the help.