LAN printer to Wifi, best way to do it

Hello All,

I purchased a GL-MT300N-V2 to solve a problem: I have a 3d resin printer which has LAN network connectivity (rj-45) but I don’t have any cable near it and I found the printer needs to be in the same subnet as the PC running the slicing software.
Using WDS is okay but I noticed a bunch of my other wifi devices now connect to the Mango and I don’t want that. Is there a way to setup the Mango where it would only server the printer and still be in the same subnet as my main router?

Thank you for any info you can provide.

You can connect the Mango in repeater mode to your main router and disable wifi. It will act as a wifi client, giving wifi to anything connected to the LAN ports.

1 Like

I already tried and there is 2 issues:

  • printer will not be in the same subnet and will not receive the broadcast from the slicer
  • Mango will not reconnect after reboot if wifi is disabled.

Can you try setting up extender which will connect your printer to the same subnet.

But I am not sure if it will reconnect if you disable wifi. If not you can change a long key and make the SSID hidden so that it will not be find by other devices.

Yes, this is exactly what I did in the end.
Thank you for taking time to reply.

I must say after a few days of usage, that the wifi connection is very flaky even if the router is 10 feet away from my main router in direct LOS (getting a 16% packet loss and latency from 7ms to 3400ms is not friendly when your traffic is mainly udp). Is there anything I can check or change in the config to get a better and stable connection?

One possible way is to modify band width. Can you post your sta config for a check? I don’t have a exact way to solve but need to try.

Thank you for your help.
How can I get the sta config, I guess I have to ssh to the mango but I haven’t found yet what is the proper command to run once connected.

You may refer to SSH to the Router - GL.iNet Docs

Check how to via and modify files on the router using winscp.

Yes, I’m in. but I don’t find any sta file using “find”.

Maybe you can check the basic settings of openwrt

/etc/config is the folder for all configs
/etc/config/network is for network config
/etc/config/wireless is for wifi config

config wifi-iface 'sta'
    option device 'mt7628'
    option mode 'sta'
    option ifname 'apcli0'
    option ssid 'something'
    option bssid 'AC:9E:17:7C:46:50'
    option channel '10'
    option encryption 'psk2'
    option key 'somekey'
    option network 'lan'
    option wds '1'

here it is

Pls post the wifi device 7628 config as well where radio parameters are defined

config wifi-device 'mt7628'
    option type 'mt7628'
    option htmode 'HT40'
    option ht_txstream '2'
    option ht_rxstream '2'
    option hwmode '11g'
    option noscan '0'
    option txpower '20'
    option txpower_max '20'
    option country 'US'
    option region '0'
    option band '2G'
    option mimops '3'
    option wmm '1'
    option channel '10'