LED Config

Hi,

Are there any instructions on how to configure the LEDs.

I would like to configure the LEDs to show the VPN status (disconnected, connecting, connected) but I’m not sure exactly how to go about this.

Thanks in advance :slight_smile:

I attached a picture for you.

I am using AR300M.

Step 1: configure OpenVPN and let it connected

Step 2: go to Luci, System->LED Configuration, and click “Add”

Step 3: Do the same as in the picture. You should find “tun0” in the interface as shown.

Note: In “Trigger Mode” there is “Link On” choice. I didn’t select this. So now only when openvpn is has traffic the LED will flash. I think this is enough. If you tick “Link On”, they the LED will always on. Even when it cannot connected but the Interface will not disappear. So I suggest not to select.

Alfie,

I’d like to have the light have a sort of Panic Blink (based on timer for 50 on 500 off) when the tunnel is not connected. Normally I’ve achieved this with up/down scripts.

It sort of works - iafter openvpn connects, it shows solid (good). BUT, when the tunnel goes down, i’d like it to revert back to the timer 50/500 setting. Is that possible without an up/down script?

 

Thanks,

 

Maybe this is not possible to configure directly. Have to use script.

Hi, I’m trying to follow the set up in the figure attached above but on a 300m v2 with the latest firmware there are three sets of configurations. the first named wifi has

led name gl-mt300n-v2:wlan

trigger natdev

device ra0

the second named VPN

led name gl-mt300n-v2:wlan

Trigger natdev

device (empty)

The device options are wlan, wan and power

How do I set it up so the middle led flashes when VPN traffic is present?

 

 

The middle LED should have name lan or wan, not sure, you need to try

device is generally tun0, this should be in your ovpn file. Check this when openvpn is connected.

 

Hi, I am using an AR300M16, could you kindly send the screenshots of the configuration (or a simple guide) to me too? I do not know how to configure the system to assign the center LED to VPN. In practice, I would like you to tell me if the vpn is active or not.
Thank you very much for helping!

Have you ever sorted this out? I’m having the same issue. Even in the Advanced-Luci config, if I try to add an LED config, I’m not able to select the TUN0 or OVPN interface (not even an option when the TUN0\OVPN interface is up).

You need to add one LED config, choose Netdev as trigger and then you will find tun0.

You must have openvpn connected first before you have tun0.

image