Login problems in 'Advanced'

Hi alzhao,

Router: AR750
Software version: 3.010

I am having a problem logging into the ‘More settings/Advanced’, that is, into openwrt as root.

I have already successfully entered the password for the admin page, but openwrt will not let me in as ‘root’, with the same password.
It says: “Invalid username and/or password! Please try again.”

I have changed the admin password at least two times, and it is not the default ‘goodlife’.
The username appears as ‘root’. My usual admin password does not work here.

Resetting the unit would cure this problem, but I would rather not do that, yet,
I have quite a lot of other settings including a Wireguard server running, and these would be lost.

It looks as if ‘root’ does not have the admin password.
Can you duplicate this problem and/or suggest a fix?

It is possible that I changed root’s password from within openwrt.

 Tony.

Can you use the password to SSH into the router?

No, I have tried this, but I think the reset button may be the only answer!

Can you read your /etc/shadow and tell me which user names have a password set.
If there is an “admin” then maybe I can log in as him.

Can you get in on ssh as “root” or is it “admin”?

In this case, restore factory Settings to resolve the problem

Your password contains certain special characters, correct? Try setting a password with no/less special characters and try to login to LuCI or SSH.

Yes it does have a special character. I changed it to “password” and now I can log in over ssh.
Why is this a problem?

Thanks oilheap for your reply.

Tony