Login redirects to LuCi on GL-XE300

I installed Luci on a new GL-XE300. Once I rebooted the Luci login page came up, instead of GL admin. I tried the following, but it always redirects to the LuCi page:

I cleared the browser cache and it is still the same. I can reset the router to get it back, but how can I have luci and still be able to use the webadmin panel?

Edit: Is there something I can do from luci or over ssh to fix it?

1 Like

I have the same problem with the XE300.

Same problem, had to do a factory reset. This is after trying to install transmission but it didn’t work. There’s only transmission-luci in the repos, no transmission-daemon or transmission-cli.

Filed a bug internally.

Same problem here.

The reproducible steps can be:

  • Install some openwrt plugins which requires luci.
  • You get luci,luci-base,luci-compat installed. (DO NOT REBOOT!)
  • As the first time, you will access directly via /cgi-bin/luci , and get login page from luci again. Login again.
  • Then if you currently not logged in the original panel, you will get 403 unauthorized when you try to access the plugin page you’ve just installed.
  • Login from /#/login and then access luci from Advanced menu. Login from luci again, access plugin page, works fine. Both /#/login and /cgi-bin/luci is currently working.
  • You just powered off normally.
  • After you power on it tomorrow, all web-ui access will be auto redirected to port 443, and since access luci page will require you to install a theme like luci-theme-bootstrap, the static resource and other path will be overridden. Trying to add option redirect_https '0' in the main part of /etc/init.d/luci will not work. Currently, I have no way to access the original panel.

This would lead users have no way to access 3g/4g modem configuration anymore.

install luci-proto-3g will not work. Use luci-proto-qmi instead.

Most openwrt packages based on luci, could you please stop use a propietary panel written via NodeJS, and just use luci as the base for modification…


Is there any method to completely remove propietary webui panel and switch back to http instead of https?

@DigiGnomad @DienoX @expresspotato

The problem might caused by the installation of luci. This operation will replace the default http server from lighttpd to uhttpd.

There’s a temporary workground here:

  • Access SSH.
  • (Optional) Disable HTTPS redirect in /etc/lighttpd/conf.d/30-openssl.conf

Then Run the following commands:

  • /etc/init.d/uhttpd disable
  • /etc/init.d/lighttpd disable
  • /etc/init.d/lighttpd enable
  • /etc/init.d/uhttpd stop
  • /etc/init.d/lighttpd start

You will have access to the original panel now. BUT if you wanna open luci, you’ll always get 403.
So after those modification, PLEASE REBOOT!

all things will work as usual.

Bug here: If you use the Advanced menu from proprietary panel, you’ll always get 403 when login.
To avoid it, access /cgi-bin/luci directly from another browser session or just directly input the url of /cgi-bin/luci.


Via SSH I ran the following commands:
/etc/init.d/uhttpd disable
/etc/init.d/lighttpd disable
/etc/init.d/lighttpd enable
/etc/init.d/uhttpd stop
/etc/init.d/lighttpd start

Went to, and the web admin login page came up.
Went to, and luci came up.

The workaround works. Keep in mind that any URL using HTTPS will redirect to luci.
Also, using will also redirect to luci.

One last note, accessing luci from Advanced brought up the luci login page, but using http, and the password did not work. Editing the URL to use https did work.

Thank you @kmahyyg

1 Like

Same for me but I didn’t need all the steps before, just replaced http:// by https://

Another take on this issue of luci redirects - it may help someone…

I bought a ‘mango’ GL-MT300N-V2.
updated to version: 3.216
Installed Luci, as I wanted to use a familiar interface to setup things like static leases, etc.
This morning, I found that I could not access the ‘normal’ webui, with constant redirect to http
What I found is that even visiting http or http redirected. Looking at the chrome dev console, the requests were replying ‘not modified’.

The issues came down to this: I have another (openwrt router) which is also running, as I am setting up a main and spare. Chrome had cached pages from from the other router, and these ALWAYS redirect to luci login.
When I did ‘empty cache and hard reload’, everything came good.

I know my situation is a very strange one, but maybe the http server should be configured not to return ‘not modified’ such that the user always gets the page served, not some stored version from chrome? after all the majority of interactions with the UI will be local.