Losing internet on Beryl in repeater mode

I have a brand new Beryl with firmware updated to 3.211, and I’m having a couple basic problems. I’m using it in repeater mode.

  • When I connect with a client in 2.4 ghz, everything works fine. When I connect to 5 ghz I don’t have internet access. Not really sure what’s going on here.

  • I’d like to set my lan IP to 192.168.1.1. But when I change it from the default (192.168.8.1) to this I lose internet access. The lan works fine–I can connect and see other devices in it, still access the settings page for the decide, etc, but I no longer can get internet.

Thanks for any help! I like this device a lot but am a bit baffled here.

If it is a a problem brought up when upgrade, you may need to reset your firmware.

Also 192.168.1.1 should be OK. What is the Internet connection, cable?

Thank you for your response. Sorry if I said something misleading --it’s not that it worked before the firmware update --I updated the firmware first thing. I’ve since experimented:

  • On both the most recent stable and on the older firmware, I can’t get internet if I change the LAN IP to 192.168.1.1

  • Others do work: e.g. 192.168.2.1 works, as mentioned 192.168.8.1 works. Only 192.168.1.x results in no internet (I’ve tried eg 192.168.1.5, 192.168.1.10, etc.)

  • I’ve tried with multiple clients, so it’s not just idiosyncratic settings on one device.

  • I’ve done a factory reset and rolled back the firmware; same thing is happening.

  • This is all in repeater mode by the way. No wired connection.

Any theories why I can get internet with other LAN IPs but not 192.168.1.x? Anything I can do to troubleshoot?

What is there ip of the upstream router your connecting the gl router to?

1 Like

If you want to use 192.168.1.1, just box it up and send it back. You shouldn’t be on the internet in the first place. :grinning: Naw, just having fun–that was the old Wordperfect joke.

Because 192.168.0.xx and .1.xx are so common in devices, there is a good chance that somewhere in your path, especially if you are doing VPN to someplace else, that you will traverse another 0.1 or 1.1 network. You may have an ISP modem in the mix which also uses 1.1, although for this very reason most are 100.1. But for giggles, what is the IP of the WAN side of your Beryl? If it is a 1.xx address, you can see the problem.

Seriously, though, if you stay off of 1.xx or 0.xx on any network you have control over, you will save yourself pains down the road. The one exception I make is both my Mango and my Beryl are 8.xx schemes, and I travel with both. It’s only because I’m not using them at the same time that I’m not having problems. If I did, I would.

On your other problem, I think you might try the latest snapshot firmware. There are fixes in there for other problems, not yours, but it is working for me (I had the wrong key problem on the 2.4 band but not on the 5 band with a 4/20/22 snapshot, and not on the 6/29/22 snapshot).

Thanks. All good points. The address of the IP that the Beryl gets on the WAN is 192.168.7.217, but your point that somewhere something could be using 192.168.1.xx makes sense. If this isn’t a known problem or whatever and other addresses are working, clearly there’s a conflict with this one.

When I’m back on my own network, I may experiment a bit to verify. But your point that I’ll avoid grief down the line by just choosing something less common is extremely well taken. Thanks a ton!

I had this issue and it was because the router was connected to a router on the 192.168.1.1 pool so it didn’t agree and had to be put on another pool 192.168.x with the same subnet mask 255.255.255.0

Then there’s finding other machines on the network because the pool is different.

Usually the router should just sort itself out and you have to do very little if you just use the webui. Mine worked well until I messed with it. Now it keeps the dust off my shelf…

Hi, I am having the same issue, except that while I can connect the Beryl to both 2.4 Ghz and 5 Ghz wifi to my router which has internet access, I can’t connect to the internet via the Beryl.
Have you found any solution to this problem?
Any help would be appreciated. Cheers

For any problems pls upgrade to 3.215 beta 3 to see if it solves.

If not, just post log.

Routers don’t like being in the same IP pool if they both want to control dhcp. Only ONE dhcp server per pool. The dhcp server should also be the gateway. Eg 192.168.0.1

You can add another dhcp but it must be on a different pool eg 192.168.1.1, again it will also be the gateway to THAT POOL ONLY. That router will do the forwarding to the original gateway 192.168.0.1 automatically.

So long as they are on the same subnet (255.255.255.0) they should be able to communicate with each other. If not then try installing the upnp plugin to mitigate firewall problems.

If you are intent on having the gl router as a ‘dumb’ router then you can disable the “authorative dhcp” in LUCI, which should allow the router to play nice.

Good luck.