Loving my MT3000 but now locked out as admin? seriously

Was loving my MT3000 experience for about the last week. Suddenly i cannot login as admin anymore. Keeps saying wrong password even if i SSH in as root. This worked perfectly for a week - now totally locked out. I have a backup of the config so i suppose i can reset to factory but this shouldn't happen. Is there some factory router admin password i can try as a last resort?


If you lost the password (for whatever reason) you need to reset the device.

Luckily, no, as it can be exploited by bad actor.

That’s why you should use password manager

I didn’t lose password. It doesn’t work anymore. I had the password written down and also saved in 3 different browsers and none of them work. Something glitched in the firmware/router!

Can happen depending on what services are active and what your router does.

Sorry to hear anyway.

If something or even worse someone is changing my well kown password on my device, I really would like to do a factory reset.
Via external image (uboot), not with button reset.

This is definitely not standard behaviour, but to me this also not sounds like a GL.iNet issue. It it's rather a very device specific issue.
But hard to say without knowing anything about used packages, open ports, environment, ... just a wild speculation from me.


This happens to me following a scheduled reboot, the password doesn't work on the GL.iNet login but still works on the Luci login. I thought I'd simply forgotten it at first but reset the device and it's happened again the following day without setting a distinct password in Luci.

interesting - it was post reboot that it started acting funny. Unfortunately the device is physically 2 hours away at my cottage and i'm able to access via VPN but can't physically press the reset button. I have a backup that i'll restore but super concerned this doesn't happen again. I may just go to the new beta firmware:)

which firmware version are you using?

latest production firmware - updated a week ago when i got the router. I have not tried any of the beta/pre-release. This has me rethinking going back to my trusty but hard to use Unifi Edge ER-X

Because there was an issue once?

But that is a very overdramatic reaction.

The question that arises: Why does the login no longer work? To shed light on this, you would need to know what you have set up. Were there perhaps even manually installed plugins at work here?

Understood - i will give it another chance as i love everything else about it:)

Yes there were a few plugins. I think the only way to get back into the router will be through a factory reset?.

What i might do is rebuild the config without restoring the last backup so i don't have any of the plugins (which were non essential). My internet connection was a dead simple DHCP from WAN port to a 5G router - wifi turned off as i have Unifi APs and OpenVPN client configured back to house.

Guess so, yes. If login does not even work via SSH (root / password) - reset is the only thing you can really do.

In very early versons the web page login can be different from Luci (ssh). So seems a different issue. But in firmware 4.x this should not happen.

Did you ever enable WAN access or share the vpn with others?

Or anyone else has the right connecting to the router?

1 Like