MAC clone with GL-MT300N not working?

I have a GL-MT300N with firmware 2.16.

In the custom GL web interface, there is a “Clone MAC” option in the “Internet Settings”. However, when I change the MAC and hit “Apply” the device becomes unreachable until I reset it again. Is this a known bug?

I would like to use the device as wifi client and there are times when I would like to change the MAC to resolve problems. When I travel, it is not uncommon that things work again with a different MAC for some reason, so this feature would be VERY helpful for me.

Thanks for reporting. Will test and come back to you.

@jogl, I justed tested and I don’t have any problem to clone my mac address.

What mac address did you change to?

I’ll check again tomorrow. I tried several, I tried some from two of my normal devices and some based on the device MAC and changed some random parts to test, e.g. if the mac ended with …:ee I chose …:e1 instead.

Maybe I should note that I was connected via Wifi to the GL-MT300N and it was connected to another Wifi router as client. I did not try if changing the mac works when using a wired WAN connection. Although I also tried when I was connected to the LAN port. I had a brief look into the logs and there was some error with the - I did not test more, because I always had to perform a reset to get the GL-MT300N back to access the internet and I tried it multiple times with different MACs. Can you give me an example MAC to test that you know is working for you? Did you test it for the wifi client mac (not wired)?

Thanks for report. I just tested, mac clone on wifi STATION mode is not working on MT300N. I am not sure if this is a software bug, driver or hardware limitations. I hope to find a solution.

Any news? This feature would be quite important for me.

@jogl, unfortunately we cannot solve this problem so quickly. This problem is not in any of our other models, only MT300N. I am pushing our engineers to solve this.

OK, thanks. Is it at least clear already if it can be fixed?

Are the AR150 and MT300A not affected?

It is not clear about the reason. MT300A and AR150 do not have this problem.

Doesn’t the MT300A have the same chipset as the MT300N? I see the MT7620A in both descriptions.


MT300N uses MTK7620N SoC

MT300A uses MTK7620A Soc

These two chipset has similar specs, but MTK 7620A (MT300A) support PCIE and MMC storage.


I have the same router, which has the same problem. It would be good to find out how to solve what problem.

Is there a possibility to change the MAC address by my self? (without UI)

@kaulazs, no. It is not the UI. It is something in the driver which I didn’t figure out. So you cannot change by hand.

After a thorough test, I have to say that MT300A doesn’t support changing mac address in repeater mode. I made some mistakes in my previous test.

Atheros chips don’t have this issue.

Does this mean that the MT300A and MT300N both do not support changing the mac address at all? That it is not technically possible? I had ordered a MT300A hoping it would support this feature.

To be precise, it doesn’t support changing mac address for wireless interfaces when you use as repeater and ap at the same time.

But it can be used to change mac address when in ap mode only.

Is it possible to solve this with software in the future? The MT300A is not better than the MT300N in this respect?

Hope that too :frowning: i bought two and am not using them …

Hi everyboad, after a deep investigation, I solved this problem.

Now both MT300A and MT300N can change mac address when used as sta and ap combined.

I will update the firmware asap.