Make LAN subnet the same as repeated network's

I connected my MT300N to another wireless network using Repeater mode. I also converted the WAN port to an additional LAN port. The MT300N’s IP address is The subnet of the primary network is 192.168.1. Both of the wired devices that I attached to the MT300N have the router’s subnet of 192.168.8. I want the router and its LAN devices to have the same subnet as the primary network (192.168.1). How do I go about this?

There are a couple of options, but these involve using standard OpenWrt tools.

Some of what you can do depends on the hardware in your primary router and how well it talks to the GLi device.

Not sure what Mediatek supports.

The fall back is using the relayd configuration discussed here.

Just to be complete, if you use a cable to connect the MT-300N to your home router, you can just configure it as a “Dumb AP”


Also, I should note that the instructions here seem like they do what I want, but they’re outdated. They mention doing everything with LAN and WAN, but there’s a WWAN now. I tried replacing WAN with WWAN, but that didn’t work. I also tried replacing WAN with WAN and WWAN, but that didn’t work either.

My primary router Netgear R6400 does not support WDS, so relayd is the path I’m investigating.

As docs here:!mini/

If you use repeater mode and want your subnet is the same as your main router, the right configuration is WDS. So in GLI UI you can just configure WDS repeater.

Unfortunately your main router doesn’t support WDS. Configuring WDS will make the network unusable. If your mini router don’t broadcast ssid any more you can press and hold the reset button for 3 seconds (until you see the middle LED flashing more quickly) to disable this repeater. This works in v2.22

So you need to use relayd, which we have docs also in the above link.

Thank you I was able to get it working with the instructions you listed here: Routed Client with relayd (Pseudobridge) [Old OpenWrt Wiki]