Mango GL-MT300N-V2 won't bind to cloud

Following on from this, the latest version of the GL-iNet app now shows me my devices without having to connect to any. Yay :grinning:

However, it won’t let me connect to my Mango. Following another post with a similar issue, I removed the Mango from the Cloud. But now, when connected to it and trying to re-bind, I get a pop-up saying “Permission error”.

The Mango is running 4.3.7 (release4) and the Admin Panel shows GoodCloud enabled.


Please check your private message, we need some device information to check the problem.

I am getting the same with my Beryl AX, what was the solution?

Hi, I am having a similar problem, can you send me a private message to get this fixed?


Hi @Eheasterweekend

  1. what is the firmware version of your Beryl AX?
  2. Could you please turn off the GoodCloud on Admin Panel of Beryl AX, then turn on again.
  3. If it still not works, could you show some screenshots of the log.

For v4.x, you can find the log as below.

I turned it off and then turned it on again, that seems to have worked. Thanks for the help!