Mango V2 advanced mode error

I have a Mango V2

when I go to Advanced Mode>Wireless, I get following error

package libiwinfo required

Please advise how to address that.

Just to know. Have you tried to install the package libiwinfo in the app repository and reboot ?

please check and post your firmware version

corection, it is ‘libiwinfo-lua package is not installed…’

@luis 'tried opkg install libiwinfo-lua, get, Package libiwinfo-lua … installed in root is up to date.

@Ranger 2.261

Tom, I noticed the same thing, and I think the bssid portion doesn’t work either. Here’s what I was told by the mfgr when I pointed out that error:

“MT300N-V2 has MTK driver so luci configuration doesn’t work good.”


Tom, I suspected the -V2 had bugs so I bought the non-V2 version and just got to playing with it. There is NO issue with the error you and I saw. Luci works okay with the Wifi settings and I can even set other parameters which I could not on the V2.

FWIW, I also had other issues with the V2

  • would not auto connect to another AP when the one currently connected goes away. The non-V2 does this quickly.

  • other menu issues in that the -V2 won’t refresh the connection summary with new connections, also when creating a repeater connection it would just spin and spin though the connection was there. No issue with the non -V2.

This is with version 2.25 on the non-V2

I am returning my -V2. It’s not ready for prime time.

@AlpineJoe, thanks for the info.

If you are not aware there is a ticket system for reporting bugs


Well put RangerZ - seems I wasn’t the only one turned-off with Alpine Joe’s whinging and spamming of the forum!


Will check the problem you mentioned. V2 firmware is new so it may have more problems than others.

Thanks Ranger - bugs entered.