Mango v2 does not connect to WiFi and iOS tethering not working

Hi, yesterday I bought the GL-MT300N-V2. After having problems getting it in uBoot (for me it was not clear that it requires 5 led flashes instead of 3) I was pretty pleased with its functions. OpenVPN with killswitch worked great connected via cable. But then I wanted to connect the router to WiFi of another router but I could not get a connection, also the advanced OpenWRT UI didn’t help.
With OpenWRT 19.07.6 it worked but I like the easy to use GL iNet UI so I would be happy if you could help to get it done with the GL-iNet Firmware or release an update.

Edit: Further tethering does also not work with iPhone SE iOS 14.4 via USB.

If you use firmware 3.105 it should just work.

I just tried AR750s 3.105 with IOS14. It works just ok.

Doesnt work for me see screenshot.

Yes, I too, have found that the Mango2 w/3.105 also works fine with iOS 14.2. I don’t think I tested it with 14.3. 14.4 is still in Beta so I cannot comment.

BUT, this new firmware breaks the QoS client speed throttling feature. There are other threads about it.

Make sure you manually turn on tethering on your iPhone, too.

No, 14.4 got released several days ago. And I do have the personal hotspot enabled which also enables tethering right?

In case it helps:

Yes. You have to enable personal hotspot.

Ok I never did it somehow else so thats not the reason why it is not working.

Edit: The tethering thing is not my main problem I just wanted to point that out. More important for me is that the repeater mode does not work for me. Actually I do not really need repeating I just want to connect to an availble WiFi network with the Mango router.

Any details? It should work

Yeah I’m having the same issue im running IOS 14.4 of an iphone 11 pro connecting via usb just upgraded my firmware on the mango to 3.105 and still wont connect to my hotspot.

It keeps asking me to trust the device so I assume theres some issue on the mango’s end perhaps.

Actually I do not get any message on the iPhone SE. I’ll tell later how the problem actually turns out for me with the repeater option not sure if I remember it correctly.

I just flashed a plain v3.105 to the router. It looks like it cannot handle special characters in the SSID password. When I connect to my main WiFi network (numbers and letters only password) it works but not with guest WiFi (password includes special characters). I would aprreciate it if you could fix that. Thanks!

Edit: It also looks like it is not capable to roam between different APs of the same WiFi network. As far as I could find out it sticks to the MAC adress of one AP which is not the best solution in my opinion.

You can remove the special characters and try.

It should be able to roam between APs with the same SSID and Password. But it does this slowly. Only if it lost connection it will try to reconnect.

I’ll try the roaming thing. Removing any special characters from the WiFi password does not sound like a reasonable solution to me. :wink:

It is only some special characters that make it fail. Some users had spaces in the password and removing them worked fine.

Here is an interesting list:

My recommendation is you have a long phrase as the wifi password. A shorter password with special characters or a long password end up having the same entropy.