Mango V2 no clean firmware install & reinstall breaks

Hi there

When loading a fresh Mulvad-Wireguard Profile, Mango V2 (firmware 3.102) gets a timeout each time.
Problem is:
There are many configs to be loaded, and the timeout occurs before all are loaded.
When I reload the page after some minutes, the profiles seem to be there, sometimes, on another reload they disappear again … the wireguard-Profiles seem unstable, they don’t allways show up ( same is true for the connections. i wonder if the configs are not being loaded correctly because Mango v2 is overwhelmed by the amount of loaded configs.

What can be done? I already reset the router 3 times, each time with the same outcome … and my wireguard-connections are unstable too now.

thanks for all & stay healthy :slight_smile:

… to get a clean firmware again, after overwriting the system 3 times with 3.102, I tried to reset my Mango v2 by installing the TOR-firmware (lede-mt300n-v2-tor-2.2641) … hoping afterwards I could overwrite it with a clean(!) 3.102 … bad idea …
Now I can not access the admin-interface at all anymore.
Tried unbrick via uboot, but it does not work. I can not talk to the Mango via, nor anymore.
The Router now connects to the TOR network, but I have no way to access it’s interface and install another firmware anymore. u-boot seems gone too … tried from Mac and from PC.
Hope this isn‘t a total brick.

Move the switch button to the other side and get off the Tor network. Then you can connect to the router UI again. This is the design of old tor firmware.

Uboot should still work. Just some times it is weird.

at least I got it unbricked …
Problem was to set all necessary settings in “Network”-Settings of the Mac
not just IPv4, you need to also set the subnet-mask and the Router
only after also filling the subnetmask, I could access uboot-webinterface via

1 Like


So i re-installed the latest Firmware again, router-interface working … but:

Issue with adding Mullvad-Profile persists:
I get a time-out when installing Mullvad Profile on fresh install.
The Profile does not show up in the Wireguard-Client-Settings.
When I reload the page after some minutes, the profile show up, but not all of them. Maybe config-files are not getting properly loaded because of the time-out? There are 300+ Mulvad-configs to be loaded … does this just freeze the Mango?
any help about this @alzhao ?

I have a couple of gl-inet-Routers running Mullvad for years, never had this problem with when installing the Mullvad-WG-profies before …

Seems the UI is slow. Rendering the list of profiles take a lot of time.

I will test Mango.

I confirm this happens. I will record this as a bug.