MangoV2 SOCKS5 Proxy is Always "NOT RUNNING"


I reboot the router and it always says SOCKS5 Proxy: NOT RUNNING

Can someone please help me

I got the server information from my proxy provider.

I set up in LuCI, Services, ShadowSocks, General Settings, Socks5 Proxy;

Server: (Full IP Redacted)

Local Port: 1080

Override MTU: 1492.

I also added that same server in LuCI, Services, ShadowSocks, Servers Manage as:

Alias(optional): Test

Server Address:

Server Port: 5080

Connection timeout: 60

Password: *************** (how can this work without a user name)

Directly Key: Nothing Entered

Encrypt Method: RC4-MD5 (not changed from default)

Plugin Name: Nothing Entered

Plugin Arguments: Nothing Entered

Please help me get this proxy thing running.

Thank you

Please note this is shadowsocks and you have to make sure it is the same protocol (shadowsocks). I assume there are different Socks5 servers.

I use ShadowSocks on windows, enter the information I was given by my provider and it connects.

I use the proxy function of Firefox with the same server information and it connects.

I use ShadowSocks on the router with the same server information - reboot - and all I get is:

<label class=“cbi-value-title” for=“cbid.shadowsocks.cfg02f223._local_status”>SOCKS5 Proxy:</label> <span id=“_local_status”>NOT RUNNING</span>

It is not due to the protocols used on the provider’s server which are:

OpenVPN(UDP), OpenVPN(TCP), IPSec, SSH2, PPTP, Squid Proxy, SOCKS5 Proxy and TOR.
Thank You


Good news of sorts.

I now have SOCKS5 Proxy RUNNING.

I was using the Squid Proxy port in the server definition.

When I changed to the the server definition to use the SOCKS5 port, I got a connection.

But, I don’t know where to go from here.

I added one LAN host on the Access Control page but that box is still connected to the ISP, not the proxy.

Now that I have the proxy connected on the router I had this wild dream that all devices on the LAN would now have their traffic routed through the Proxy.

I guess dreams are only made to be broken.

Does anyone know where to go from here?

Thank You


@tank, I think the traffic should be routed automatically as this is the default action.

Hello Alzhao,

No, it’s not automatic.

LAN is still connected to WAN and WAN6 and no traffic moves through the proxy.

There are dozens of possibilities making for thousands of combinations.

I don’t even know whether I should be creating a new interface for the proxy and undertaking the daunting task of inserting it between LAN and WAN and WAN6 interfaces.

Right off the bat it would not let me enter for the IP address of the new interface.

That’s the IP of the proxy server but it will only let me enter the portion and there is no box to enter the port 1080.

OR, is it all done through the proxy interface pages. I don’t have clue.

I can connect any or all of the three proxy types to my proxy server provider but nothing ever changes to a tracert.

Without a step by step tutorial where someone details each step they used to successfully insert their proxy between all LAN to WAN traffic, it’s impossible to figure out with trial and error.

The thousands of combinations on multiple pages makes trial and error useless.

I have searched everything for two weeks now and can count on both hands anything that has to do with LuCI/LEDE proxy configuration.

I find nothing that shows how to insert the newly created proxy between the LAN and WAN.

And with that note, I give up.



Sorry for not helping fast. I will test in my side.

Thank you, I have an update.

I have a proxy provider that provides PPTP (1723), SOCKS5 (21, 508, 5080) and Squid (3128, 8080) connections.

I have defined all three servers on the Servers Manage page, using. PPTP (1723), SOCKS5 (5080) and Squid (3128).

On the General Settings page in the Transparent Proxy Section, I set the Main Server to either the Socks or the Squid server and reboot the router and the computer.

Now tracert takes a different path to yet every server along the way still belongs to my ISP.

My Proxy provider’s server(s) don’t appear and now all HTTP and HTTPS don’t work.

I cannot browse any internet pages. HTTPS says it cant negotiate security and HTTP says the server reset the transaction.

Same deadness with either SOCKS5 or Squid. I also tried adding UDP-Relay Server = Same as Main Server. Still deadness.

I can proxy to either one successfully with Firefox proxy settings as well as Internet Explorer proxy settings.

I tried setting all three servers in the SOCKS5 Proxy Section and saw no changes at all. No change to tracert no change to Firefox.

I don’t know what the Port Forward Section is for so, I have done nothing in that section.

There are three pages to the ShadowSocks interface and multiple choices within a page that makes it impossible to trial and error a solution.

Can anyone please provide a working example or simple tutorial that shows what is put in what boxes on what pages in someones example of a working proxy on this router?

It would be especially helpful if this example used a free public proxy service so anyone could directly use the example to prove that their situation works before embarking on changes to their personal situation.

Thank You