Manual DNS, GL-AX1800 v4.1.0

I have found out that setting a manual DNS in Network > DNS doen’t work correctly.

The scenario is the following:
I have a local DNS Pi-Hole sever on another machine to filter the traffic and it is cofigured properly and working.

When its IP address is set as primary DNS server BUT without any other (optional) DNS all the traffic is rooted correctly and filtered by the Pi-hole server.
However, when any other optional DNS is set (like, the primary DNS IP is ignored and no traffic goes throught the primary DNS?! I need this to work properly - like on my old router - the traffic always passes throught the first DNS, and if is somehow inaccessible the traffic goes throught the second or other DNS server. I need to set a “backup” manual (optional) DNS server because in rare ocassions the P-hole sever may hang or the its OS gets updated or restarted and this will lead to lack of connection on the whole local LAN in such intervals.

“Override DNS Settings for All Clients” is set to ON as well.


FYI, this link tell the parameter of strictorder.

To apply this on GL-AX1800
use command:

uci set dhcp.@dnsmasq[0].strictorder=1
uci commit dhcp

One thing to note is, Manual DNS “DNS Server 2” has higher priority than “DNS Server 1”.
Without strictorder parameter, both dns server is requested at the same time. The quicker response is used by DNS queries I think.