Mesh not working S1300 firmware v3.102

Hi.
I have two S1300 devices, both running 3.102 firmware.
One is setup as my main Wifi router. I wanted to extend the Wifi coverage using the second one, with Mesh mode.
I followed the instructions on the Docs, and read some forum topics, but still couldn’t get Mesh to work.
The slave device always flashes the Mesh LED, while on the master it is on solid.

I think Mesh mode is broken on latest testing firmware v3.102.
I hope that this will get fixed soon. Also waiting for a new release version, as v3.029 is almost half a year old.

@meetyg

Does this help? (Ignore the lights) :slight_smile:

As mentioned in another review, the documentation is a bit lacking about meshing, the basics are there but perhaps not the detail. After mucking around here’s what I’ve found to work:

  1. Connect your router to the master node via it’s WAN port and setup as indicated in in the documentation
  2. Connect a device to the master node and go to 192.168.8.1 (the default ) IP to get the Web Admin Panel and note that the second line item on the left hand menu is “Wireless”
  3. On the master node press the right hand side of the button on the front (the mesh button) and after 5 flashes it will start to flash a bit quicker, release the button.
  4. On the slave node (which you don’t even have to setup first), push the mesh button and again after 5 flashes it starts flashing quicker, release the button.
  5. Wait… I thought I had some bung units initially because nothing would happen so I’d reset the routers and start again. Setup of the mesh takes a little bit of time. Patience grasshopper, patience!
  6. Keep an eye on the Web Admin Panel of the master node. Refresh the page a few times. You will note that the “Wireless” changes to “Mesh”
  7. Click on “Mesh” on the web interface and you should eventually see “Main Node” and “Sub Node 1”.
  8. You now have a mesh.
  9. If you want to add another node, repeat steps 3-7 and you should on the web interface, eventually see “Sub Node 2”

Might I ask with to which device you want to connect the Mesh? There are some OEM manufacturers who make it either complicated or make you buy their house-own repeater. What helped for me on my device (AVM) was tto put it via lan in, since it’s a gbit lan but it has only 100mbit pro port it automatically takes more via 5g, when needed. No long time study on that since I unfortunately bricked it right after while flashing … DD-WRT firmware itself supports also OLSR and it’s the best solution imo. If your router you want to mesh with is from your ISP and branded, nothing will help. Sad that you basically need open firmwares on your devices to use good ideas like mesh in general…well we need (over the whole planet) more mesh networks, not less, it would be great and completely free to use. Packages that also helped are HAProxy, OLSRd and Alfred, Batman is very good I heard but for now I didn’t need it and the besides OLSR the ones I named work automatically).

Next solution would be if it’s locked by branding, just clone the mac address, change only the last character of the cloned mac. This is near enough for 99% “thinking” then because the mac address indicates it they are from the same brand and just pair

Oh, both the same? Okay I’m out then but would why.

Yes, I have tried this procedure, waiting a long time for the lights to be solid, but it didn’t work.
In the admin panel, I see no Mesh clients.
It seems that I’m not the only one having problems with v3.102. See this post:

My admin panel looks the same as his in the Mesh tab.

I know that this is a testing version, not a release. But this is the purpose of testing. We tested the Mesh and its not working. I hope GL.inet developers will address this.

Sure they will, this thing has so much potential which could really be brought out instead of the GL-AR150 from 200 years ago which has regularly updates. I mean even if you with heavy third party firewall and openvpn protocal (which eats much CPU) the thing was still snappy af, the only thing what I really found strange is that for it there’s literally no documentation on the wiki, other from a photo of the motherboard. That’s literally it. And yes I heard that it’s apparently the version before or before, before the which is about to come out soon. So long, if someone posts how to do the mesh I’ll take it from here. After de-bricking it… hopefully this isn’t too much different than flashing a gfx bios.

Mmm I have 2 fresh 3.102 B1300 here. Will try and find time to set them up in a test environment and reproduce the issue (not that that will prove anything really :thinking:)

OK, confirming the issue :slight_smile:

2 Brand new B1300 running 3.102

Can’t see the mesh slave node in the Gl.iNet interface

But can see it in the Luci interface.

Mesh is however running as far as I can see :slight_smile:

Can only see SSID of master mesh node.

Well, on my master node it also seems that Mesh mode is working but on sub node the LED is slowly blinking (forever). On devices like a phone or a laptop, I see weak Wifi signal, meaning that the sub node is not really extending the wifi.

In short, I don’t think its a UI problem only.
Its also functionally not working for me.

Looks like this was fixed for the B1300 in the newest img they just dropped yesterday (3.103).

I will try it on my S1300. Thanks

Well, here’s an update:
I updated both S1300 devices to version 3.103.
I then tried again to do the mesh setup. This time, after waiting a lot, finally the sub node also got a solid mesh light.

BUT, the mesh is still not working exactly as it should. The SSID of the sub node hasn’t changed (stays default GL-S1300-xxx, including default password), and so Wifi clients don’t connect to it automatically. If I manually connect to the sub node’s SSID, I am able to get internet access, and I see my phone’s MAC address under “sub node” mesh clients list.
But this behaviour is more like a wifi extender, not mesh since the SSID is different.
Also, the sub node doesn’t broadcast guest wifi, like the main node does.

In short, something is still really buggy with this mesh on newer versions of GL-inet firmware.

Was anyone successful in running Mesh on these S1300s ?
It seems that the community has better experience using the B1300, but not the S.

I have two GL-B1300-28b routers running qsdk-b1300-3.104-0519.img and I’m struggling to configure mesh mode to extend my wifi across my house.

After returning both to factory settings and following https://docs.gl-inet.com/en/3/setup/convexa_b/mesh the green LED lights indicate that the mesh network has been established, but when I navigate to the mesh page of the administration panel of the main router I don’t see any clients reported:

How do I confirm that the mesh network is properly configured and what client is using which router?

As you noticed there are many bugs in the Mesh configuration. Documention is very optimistic, in real life it simply doesn’t work.

When I was finally able to get the two Mesh nodes working, it seems that the clients were always connecting to the master node, no matter what.
Instead the wifi clients should have been connecting to the best signal. But it seems that the whole Mesh feature is screwed up, and latest
firmware doesn’t make it any better.

This is still not working with newest firmware v3.104 :slightly_frowning_face:

After manually updating both devices to v3.104, I tries to setup mesh again. As usual it took a long time but in the end I got a solid mesh light on both devices.

But still, the sub node broadcasts its own SSID, and client devices don’t automatically connect to it. As I mentioned before, its acting like a repeater, not a mesh sub node.

@alzhao will this ever be fixed?

Want to ask, did you try without reserving the old settings?

I will test in my side.

On the main node I save settings because its my main access point.
On the sub node I think I didn’t save settings when upgraded.

If you say that is the solution for sure, I am willing to reset both of them and start over.

If you reserved settings on your sub node, the router will not change your ssid because reserving the ssid may be just desired. If your sub node didn’t reserve settings it will sync the ssid.