MiFi Change the Ethernet to WAN or LAN


#1

Recently I’ve bought Mifi with two ethernet port. Can I know how to change the both ethernet port to the LAN port? Thanks


#2

you can ssh to the router, then modify /etc/config/network

ensure the following lines’ contents are correct

config interface lan
  option ifname 'eth0 eth1'
  ...
config interface wan
  option ifname 'eth0' #remove this line


#3

Hi! I managed to change the setting and working. Thanks


#4

Hi there,

I bought a GL-MT300A ext and I’m new to all this… I need boot ethernet ports to work as LAN, too

Can anyone please provide a step by step guide how to “ssh” to the router on Windows 10 (I have PuTTY) and change the specific setting mentioned above.

Edit: now I know how to use vi… but don’t find the mentioned setting above. I only have:

config interface ‘lan’

option force_link ‘1’

option macaddr ‘e4:95:6e:40:7e:fc’

option type ‘bridge’

option proto ‘static’

option netmask ‘255.255.255.0’

option ip6assign ‘60’

option hostname ‘GL-MT300A-efc’

option ipaddr ‘192.168.8.1’

option _orig_ifname ‘eth0.1 wlan0-1’

option _orig_bridge ‘true’

option ifname ‘eth0 eth0.1’

 

config interface ‘wan’

option force_link ‘1’

option macaddr ‘e4:95:6e:40:7e:fd’

option proto ‘dhcp’

option hostname ‘GL-MT300A-efc’

option _orig_ifname ‘eth0.2’

option _orig_bridge ‘false’

 

config interface ‘wan6’

option ifname ‘eth0.2’

option proto ‘dhcpv6’

 

config switch

option name ‘switch0’

option reset ‘1’

option enable_vlan ‘1’

@alzhao @others

Which lines should I change or remove?

Thx a lot


#5

Here is the guide to use ssh and edit files in the router.

Use winscp if you are not good at vi
https://docs.gl-inet.com/en/3/app/ssh/