MiFi: EC20 modem dead?


I have a MiFi that I bought back in Dec/Jan which I use almost every day. It has been working great for the past 6 months, and today it suddenly stopped working. The WWAN page in the router setup says “Please plug in your modem” but it’s an internal Quectel EC20 that came in the device.

I have already reset to factory and it is still not working.

Any idea how to fix this?


Can you contact cs@gl-inet.com for this?

Seems that the EC20 is dead.



I contacted customer service like you suggested,but since I was travelling soon, I decided to get this adapter from Amazon for testing: https://www.amazon.<wbr />com/gp/product/B01JGCSPEA/ref=<wbr />oh_aui_detailpage_o01_s00?ie=<wbr />UTF8&psc=1

The modem was detected as an “Android Bootloader Interface” which I know is Android Fastboot. I ran “fastboot continue” and the modem rebooted and is now working.

I wanted to respond because I am pretty sure that the problem was caused by trying to setup a GPS daemon. I don’t remember the exact steps that I went through as I was following a tutorial, but I came across this link that shows several AT commands to get into diagnostics modes on this modem, once of which is Fastboot.

I wonder if you could share instructions on getting the gpsd package working on the MiFi OpenWRT. The package is not in the GL.Inet repo.

I could also use a link to Windows 10 drivers for this modem.

@g8351427, thanks for reporting this. We will mark this down and see what we can do.

Corrected link from two posts above:

Hello. I needed to com back to this forum to update that the problem is not resolved and has gotten worse.

The modem worked fine for one day after performing the steps above, and the next day it was back to having problems.

I placed the modem back into the USB adapter and it was again in FASTBOOT mode. I reset it like before, and once the modem rebooted, it seemed to have trouble booting.

When you connect this modem to a Windows machine, it detects several hardware devices that are all part of the modem, network adapter, several COM ports, etc.

What it has started doing now is connecting to the computer then disconnecting repeatedly. It will do this about ten times then come up in FASTBOOT (recovery) mode.

It seems that the modem was failing when I first started having problems and the timing was such that I thought it was caused by enabling the NMEA COM port (which was already enabled, BTW). It has now completely failed.

I will continue to work with support, but since the modem is no longer available for purchase on your website, what are the chances it can be replaced?

The new EC25 modems have less carrier support than the EC20 does.

@g8351427, can you write an email to us. You know EC20 has a firmware and can be upgraded. We does have some EC20 having problems and solved by upgrading the firmware.

Hi @alzhao I am just curious where do we get the firmware to upgrade the EC20 modem?

I am also wondering is there a way to fully factory reset the modem to default.


Update about this issue: we need to send back to the manufacturer to repair. We cannot do it in our side. There are some modems can upgrade, but not EC20.


It seems this modem was, in fact, dead. Arya shipped me a replacement EC25-A that is working great.