Mifi - erased NAND flash

Hi all,

I think I need your help…
Having some troubles with one of my mifi v2.5 routers (reboot each time I start a 3G connection), I tried to reset it several times but it didn’t help. I updated it to openwrt-mifi-2.264.bin and it didn’t help. So I tried to see if it is not possible to do more using the Uboot cli. And I started an “ERASE ALL” of the Nand flash… (Yes without knowing exactly what I was doing ! I know… stupid…)
Anyway, now the router didn’t start anymore. I don’t have any possibility to communicate, no reaction if I push the reset button, only the power led blinks when I power it up.

What is your advice? What can I do to recover the Nand content?
Thank you for your help.

Hold down the reset button while booting. It should blink the LED a few times. Use Ethernet and assign yourself,, gateway

See if you can ping so access it in your browser and upload the firmware.

Pls use uboot failsafe.

MiFi doesn’t have Nand flash. How you “Erase all of the nand flash”?

Thank you expresspotato and alzhao, but unfortunately the router doesn’t respond to the failsafe procedure.
When I start the router with or without holding the reset button (for 60 sec), nothing happens. Only the power led is blinking. All other leds stay off.

I selected the entry “ERASE ALL” in the uboot menu (by pushing a keyboard key at a certain time) when I was connected on the uart port. If I remember well the option just above was an erase of the NAND with the possibility to select which addresses to erase. I don’t have any other MIFI on hand for the moment so I cannot re-enter the menu to verify.
You mention that MIFI doesn’t have any NAND flash. But do you confirm that the entry in the uboot menu exists. If the entry exists, I hope it doesn’t erase something other…
Anyway I think the router is dead; For info it is a Mifi 2.5 with Quectel UC20.

Thank you.

Can you give a screenshot of the uboot menu?

The default uboot should not have a menu in fact. Are you using some other uboot?

I didn’t change the original uboot or other things. The only update I did is the upgrade to openwrt-mifi-2.264.bin.
I call it “uboot menu” maybe I have to call it “Uboot command list” sorry for that. I’m not familiar with such kind of manipulations and in addition I don’t remember well what was present on screen at this time. Using the uart connection when the router is booting, you have the possibility to push a key at a certain time to enter uboot. At this time you have a menu or at least a list of available command (maybe whith the help command).

Anyway, I don’t have for the moment other mifi 2.5 on hand, so I cannot take any screenshot. As soon as I have one I will do it.
Thank you for your support.