MIFI LTE very slow

my mifi running ec25-e in hong kong, I have 4g travel router and 2 x LTE SIM CARD, I got 4-5 Mbps on MIFI, is there any problem ? how can I fix this? the following are testing result.

on MIFI:
Sim card A: 4.8 Mbps DL
Sim card B: 2.9 Mbps DL

on 4g travel router
Sim card A: 30 Mbps DL
Sim card B: 23 Mbps DL

maybe it is because the signal is not good enough in the mifi. I am in HK as well and I can get 20+ in the MiFi. MiFi’s internal antenna is not as good as a smartphone.

We are redesigning the antenna.

Ok, so can i change internal antenna? What’s spec of antenna? Or add external antenna? I found some in taobao, but dont know the requirement, 5dbi, 8dbi or? Can you advise a model for me? I bought two mifi, it’s really worst.

Hi Michael, I will ask custom support to contact you.

Hi does the antenna problem affecting older model too?

Will we be able to procure this improved antenna without purchasing an entirely new unit? I’d like to get back to a clean look without a external cell antenna poking out the side

We do redesign the antenna now. Still testing.

Keep us updated on this. I would love to buy an antenna when it’s done :slight_smile:

Also when you are done testing, post some results so we can see how the old and new compare :slight_smile:

I have an older one with an EC20. It is slow too. I’m gonna try punching out the cooling holes and mounting two antennas.

Is it possible to swap out the radio? I took out the screws and tried removing the radio card but it did not want to come out. Is it hard soldered on the back side to the domino board? I have a newer radio with better LTE band coverage that I would like to use.

There is a double sided foam pad holding the modem on after you remove the screws. You can remove the entire board after removing the screws on the modem for easier access.

Thanks. Didn’t want to force it.

It is double tap. Just remove by force CAREFULLY.

In regards to adding antennas. Here is what I did. I went from 2Mbps with internal antenna to 12Mbps with two antennas. These are small 2.5-3.5 db antennas meant for LTE usage. I did not see much improvement with one antenna.

Do not attach the internal antenna to the center GPS port as I did here, the radio and mifi got extremely hot after a few minutes and started smelling like hot electronics.

Helps if I attach the pic.

I doubt this is the correct connection.

Maybe no need to connect GPS antenna.

I would think he fried the GPS part of the module if it smelled bad…

I’m getting about 45Mbps down and 25~30Mbps up with external 10db antennas…if they are accurate in their description.

Best deal I’ve found:

Uploads were significantly improved with an extra antenna (+2x). The built in antenna is not MIMO, so it will struggle with weaker signals.

Make sure it’s in QMI mode, and not USB. USB never did more than 15~20Mbps for me, even with good external antennas.

In my experience, if the interface says 3g-modem (or tty anywhere), it’s not configured for max speed. Also, I have 4 brands of antennas…they are all close, but the ones I linked benchmark the fastest and are the cheapest, by far.

Didn’t smell like the smoke was let out, just smelled hot, like residual flux heating up or something. Not sure how to check the gps. I’ll dive into the openwrt forums and look into the AT commands. I don’t need GPS anyway. I’ll probably get a newer modem with better band coverage and maybe cat 4 or 6 when those prices come down.

Thanks for the 10dbi link. Already ordered 8dbi antennas earlier today for the same price. Guess I’ll try these too and return the ones that are lacking. I think I have some ts-9 to sma adapters, maybe I’ll use them on my other hotspots.

I just use this mifi as toy anyway. I have a few regular hotspots I use for traveling and work. I love the little gli routers, I use them all the time for little projects.

Finally, I bought this, AT+CSQ +CSQ: 30,99, seems little improved, but still not acceptable, i dont think it’s related signal, besides tested 2 x ISP SIM cannot register, any idea how to get these work?

on MIFI:
Sim card A: 7 Mbps DL
Sim card B: 5 Mbps DL

one more question, I got E3372 USB modem, how can I use it and share internet for MIFI?