MIFI malfunctioning modem

Bought a GL-MIFI (GLZT_MIFI_v2.6.3 printed on the board) with EC25-EFA-512-STD modem. Worked fine at first, but after a week or so the modem would not connect to the network anymore - on network registration it would disappear from the USB bus and then reappear again (without having registered). Reflashing original firmware and resetting to factory defaults did not fix anything. After some more time, it will not even detect the SIM card anymore. Everything else beside the modem - LAN and WiFi - works fine. Tried two different SIM cards, which both work fine in another modem, so that’s not the problem.

Any suggestions for what else can be done?

Please make sure your power supply is good.
When with other modem, what the cell info page tell it’s 3G or 4G network?

It behaves the same way on internal battery, or connected to several different PCs and a powerbank (last one with 5V/2.4A output).

The other modem sees LTE network. On MIFI I get:

AT+COPS=?
+COPS: (1,"Vodafone CZ","Vodafone","23003",7),(1,"O2 - CZ","O2 - CZ","23002",7),(1,"T-Mobile CZ","TMO CZ","23001",2),(1,"Vodafone CZ","Vodafone","23003",0),(1,"O2 - CZ","O2 - CZ","23002",2),(1,"T-Mobile CZ","TMO CZ","23001",0),(1,"O2 - CZ","O2 - CZ","23002",0),(1,"T-Mobile CZ","TMO CZ","23001",7),,(0-4),(0-2)

OK

AT+CPIN?
+CME ERROR: SIM not inserted

(the SIM is actually inserted, but the modem does not recognize it)

Does this the modem work on the same GL-MIFI? If that do, the SIM is fully connected to the modem.
Please check if the SIM is inserted okay.

This other modem is a USB stick, I use it only for checking that the SIM card is not broken.

I’m pretty sure the SIM card is inserted properly in the MIFI - I tried reinserting it several times and it didn’t work even once. I never had issues with SIM detection until the modem started misbehaving. I wonder if there could be some problem in the connection between SIM card and modem - since the SIM slot is on the MIFI board and not on the modem. Is there any way to check that?

After inserting SIM card, you should reset the modem to detect SIM, it can not hotplug-able.
Could you check the syslog if the modem report any error?

You mean with AT+CFUN=1,1? Tried that, but generally I boot with SIM already inserted. Attaching logread output, the only relevant error I can see is smsd complaining about missing SIM.

logread.zip (8.8 KB)