MiFi: No internet connection via LTE modem

I really wanted to love this device but considering that it doesn’t do two things I bought it for (WireGuard VPN and LTE connection) I’m tempted to return it soon.

Here is input data:

  1. Modem name: EP06ELAR02A03M4G
  2. Firmware 3.023 (Compile Time 2019-05-13 15:41:06)

Tested it with two SIM cards:

  1. Google Fi (router says it connects to T-Mobile but not sure if it’s true)
  2. Unlimited data EE Mobile (UK)

Both SIM card seem to be connecting to mobile network because the moment I inserted just purchased EE SIM I received text messages that I was able to see in MiFI Web Interface.

3G/4G LED on the device never lights green. Also in web interface it switches between showing that it has 4G connection to not showing that. Here are screenshots:

I saw this old thread so I ran same commands. Here are results:

uqmi -d /dev/cdc-wdm0 --get-current-settings
“Out of call”

uqmi -d /dev/cdc-wdm0 --get-data-status
“Failed to connect to service”

uqmi -d /dev/cdc-wdm0 --get-signal-info
“Unknown error”

uqmi -d /dev/cdc-wdm0 --get-serving-system
{
“registration”: “registered”,
“plmn_mcc”: 234,
“plmn_mnc”: 30,
“plmn_description”: “�”",
“roaming”: false
}

uqmi -d /dev/cdc-wdm0 --network-scan
“Failed to connect to service”

uqmi -d /dev/cdc-wdm0 --get-capabilities
“Unknown error”

I also tried configuring modem using manual mode and I also tried using /dev/ttyUSB2 device. Nothing helped.

Any ideas what to do ?

Next time help folks out - the value means nothing - had to chase down the IMEI to determine this is a Quectel EP-O6 module.

Anyways - not very interested in helping out on a Quectel Modem, but it’s Qualcomm based, so supports QMI and GobiNet…

Sierra Wireless, Telit, uBlox modems, happy to help, but Quectel, nope, not doing it.

@sfx2000 I don’t know who you are and why you think the world is interested in what you like. But Quectel EP-O6 module is what manufacturer of this router uses https://www.amazon.co.uk/gp/product/B076LMX6CH/

The EP06 is a fairly new device.

uqmi (from upstream openwrt) is fairly brittle, and I’ve had issues with modems that the maintainer hasn’t tested against.

(QMI is not strongly documented, and is a Qualcomm proprietary protocol)

qualcomm devices usually support at least two TTY devices - one for AT commands and data, and the other for debug/tracing for the modem internals - for QMI based device, you should also see a CDC-WDM device, which is the QMI interface.

Things that can be handy to debug a new device…

usbtools
minicom

I usually recommend to most to stick to the modems that have been tested and known to work - for Quectel, obviously the EC25 is a good choice.

Good luck with it - also consider the SIM card, the APN for the carrier, and the related settings for the account attached to the SIM

FWIW - my issues with Quectel are well beyond the scope of the forums here, and I’d rather not get into it.

Please provide your firewall configuration /etc/config/firewall
This can also happen if the SIM card is out of debt

We tried Google Fi on X750 and EP06 module and it works. Can your pls refer to this post and check if there is anything you can do?

https://blog.gl-inet.com/how-to-use-google-fi-on-spitz-gl-x750-4g-lte-router/

Quctel Modem is working better than before. Before we used EC20 and there are a lot of problems.

From EC25 and EP06 there are less problems.

Anyway, our firmware support Sierra MC7455 as well. The performance is similar to EP06.

Yep…

I think one item with the LTE/3G devices is to ensure a good power supply - 4G modems call pull a fair amount of power compared to wifi

1 Like