MiFi - problems connecting to APN with EC-20E modem

Hello all


I’m testing a GL-iNet MiFi with a factory build Quectel EC20-E modem. I’m in Europe (Belgium) so this must be the right modem.

I’m having a hard time getting connected to the data network. I tried to connect with the GL-iNet UI, with the LuCi UI, with SSH uqmi commands. Nothing worked…











<br />image sharing sites<br /><br />

Please give me some advice!



Modem Device: USB2
Service Type: CDMA/EVDO

I tried all the possible combinations (USB 2 / USB 3; UMTS WCDMA / CDMA EVDO)

All with the same result:

Modem connected

IPAddress: undefined

Can you reset the modem from the UI?

Resetting from the UI give the same results

Presumably you have tested the modem and SIM in a PC?

SIM is working fine in a cellphone. Modem is internally (MiFi) and didn’t test it in another device.

@Spirou_, can you please contact cs@gl-inet.com. Maybe need to change one modem for you to try.

Okay so I opened the device to have a look inside. Seems that I have a UC20 module and not a EC20.

If I’m right UC20 should work too in Europe, but no LTE. UC20 isn’t working using the QMI-interface so that might be the reason why that isn’t working. But still the UI connection should work.

On which base does the device chooses whether to use the qmi interface (for the EC20) or the classic USB data connection (for the UC20)?

Did you try to change the IMEI or use some other AT command to hack the modem? It may damage the modem.

UC20 should also work using qmi mode. If you want to use usb mode, you can change the settings manually.

in /etc/config/network

config modem
option proto ‘3g’
option device ‘/dev/ttyUSB3’
option apn ‘xxxx’

Yeah, I think OP tried to hack the modem, probably semi-bricked it while fiddling with the IMEI.