MIFI troghput very low

hello I have bought One Mifi with Quectel EC20EA-256-STD but i am having not satisfatory results with Speed.

I Only get about 6mbit max download where I should get about 30 to 40mbit.

I have an antenna with 2 cable wich I conect both at the device.

I have good siganl with “Signal Quality: 19,99” but I also tested with to go to some positions with direct view to the celular antena with 50 to 150 meters distance and get “Signal Quality: 31,99” with same results

Are these configs wright for Europe (I dont see the documentation of the options in the openwrt wiki)

config interface 'wan' option ifname 'ppp0' option hostname 'Quectel' option proto '3g' option device '/dev/ttyUSB3' option auto3g '0' option advanced3g '1' option country 'China-mainland' option sp 'China Tel' option service 'fdd-lte' option pincode '9211' option apn 'internet'



Can I improve my speed?

Do I have to activate diversity? how?

Where can I read documentation of this drivers with its’s options?


Which are the optimal settings for Europe 4G conection??

@mocho, I put EC20 AT command here: http://www.gl-inet.com/download/mifi/

The settings seems just fine. But 6mbps should be 3G only.

Can you try changing the settings to ttyUSB2 and have a try?

option device ‘/dev/ttyUSB2’

I have tryed with “<span style=“color: #222222; font-family: source_sans_proregular, ‘Helvetica Neue’, Arial, Helvetica, Geneva, sans-serif; font-size: 14px; font-style: italic; line-height: 20px;”>option device ‘/dev/ttyUSB2’” with the same or worse results.

Could someone please provide a working config with good results in Europe.

What does it mean " option auto3g ‘0’ " ?

What does it mean " option advanced3g ‘1’ " ??

Do you have to enable some config to activate the 2 antennas?

It would be very helpful if the driver options are documented




It looks to me that I am only getting 3g speeds but how can I debug it





Not one?

The options “option auto3g” doesn’t really matters. Sorry I have no idea about your scenario now.