missing packages (?)

Hi,

I received my AR300M today and have played around with it for a few hours (upgraded to firmware 2.25) - it’s my first exposure to openwrt and I’ve got a problem:

The thing seems to be configured to get packages from a repository hosted by GLI, but it seems that some packages are missing there.

For example: The package “mpd-full” is there, but that depends (among others) on “libcurl” which is missing. So it seems that not only are packages missing, but the package list seems to be inconsistent as it lists modules that cannot be installed because their depencencies cannot be met.

I also miss kernel-modules (eg. “kmod-usb-audio”)…

What is this problem here?

Am I doing something wrong, is this something that only affects the new firmware, or is it because of the architecture?

Is there anything I can do do get around this problem?

Many thanks!

We have compiled more than 5000 packages which is a lot. Of course there are always new packages not compiled.

But I don’t know how you checked.

mpd-full and kmod-usb-audio are all in the repo.

You can use our UI, go to “app repo”, the UI will try to load all the packages, which should be more than 5000 packages. If you only have hundreds of packages, it means that you haven’t connected to the Internet or cannot get access to the repo.

Ok, I must have been doing something wrong before (can’t retrace my steps unfortunately).

But I now did an “opkg update” and an “opkg install” and all went fine.

But thanks for the support.

Sorry again, I still have problems getting my sound-card to work and which I believe is because of a missing module.
You wrote:

mpd-full and kmod-usb-audio are all in the repo.
 

But for me only mpd-full installed ok and I get this when I try to install kmod-usb-audio:


> opkg install kmod-usb-audio
Unknown package 'kmod-usb-audio'.
Collected errors:
* opkg_install_cmd: Cannot install package kmod-usb-audio.

Could you please have a look again?

Many thanks!

Ok, after an update it installed.

I don’t get it.

I did an “opkg update” a few hours ago. Then I tried to install a package and it fails. Then I do an update again and it works.

Is the list of available packages that you get then you do an update somehow invalidated after some time?

Do I have to do an update every time I want to install something via opkg then?

Could this be the problem?


> ls -id /var/opkg-lists
7572 /var/opkg-lists

> ls -id /tmp/opkg-lists/
7572 /tmp/opkg-lists/

So it seems /var/opkg-lists and /tmp/opkg-lists are actually the same.
And I suppose /tmp gets cleared after a reboot.

That would explain why I seem to loose my indexes.

Why is this done this way?

Those files are the same file actually.

/tmp does get cleared after reboot. I think you rebooted the router when you do another opkg install

Yes, I believe that is what happened.

I usually work on the command-line and have no intention of ever using the web-gui to install packages.

As far as I can see the this is configured in /etc/opkg.conf.

Do you see any risk if I would configure my system in such a way that the indexes survive a reboot?

At the moment I play around it quite a bit (it’s a very nice toy!) and so I reboot and install package probable more often than is usual and this behaviour starts to get on my nerves.

But as an aside I am quite impressed with the product, so far I’ve got every peripheral I’ve tried to work - really nice work by GLI.