Mjpg-streamer not working in ar750s

performed installation and webcam setup on other make router with 18.06 luci and 4.14 kernel and mjp-streamer worked fine.

flashed a clean opewrt image from downloads.gl-inet.com to ar750s still does not work.
repositories still point back to gl-inet.

is there a pure openwrt that points back to openwrt packages that uses 4.14 kernel?

never mind.

saw this

¨There are no NAND drivers for ath79 that are acceptable for upstream Linux or OpenWrt and it is exceptionally unlikely that there will be prior to Kernel 4.19 being adopted for ath79¨

Actually you can download a firmware from openwrt for AR750S which is only for Nor flash. You can just flash using uboot and it just works.

You will lose nand but it is a vanilla openwrt.

thank you alzhao,
I have a few more questions if you have the time and can answer them.

  1. I noticed the uboot had both types of flash to upload for nor and nand.
    I hove no problem doing a nor flash with an extroot for more storage space. so can I use the internal microsd for extroot?

  2. after testing it out if it isnt what i was hoping for do I flash the gl-stock.bin file to nor or nand? I was reading that it actually boots off nor and switches to nand but the interface says to flash .bin file to nor.

  3. do you have a link for the vanilla openwrt for 750s. (hoping its a higher kernel than 4.9
    issues is probably a kernerl problem or I jjust missing some .ipk in the stock gl-inet firmware… or maybe just a plain openwrt bug?


  1. Yes you can use exroot. In openwrt you can find very detailed documents.

  2. Yes you can. You just download the .img file from our website. GL.iNet download center

  3. Just find in openwrt website: Index of /snapshots/targets/ath79/generic/

thanks alzhao,

just another quick question.
either the snapshot I downloaded has issues or Iḿ flashing it wrong. I flashed the snapshot.bin for the ar750s you pointed to with uboot to the nor partition. is that correct? I also flashed the clean.bin from gl-inet before it and it still wont boot. any ideas?

I updated uboot so now it only shows 1 upload button instead of 2 buttons(nor and nand) now I don´t have to use a windows machine only for uboot firmware upload.

been reading but cant I figure out how to update this ar750s. there are two files in the location you gave me 1 is kernerl-initrmfs.bin and the other snapshot.bin.

I have sent you the links above. You need find the glinet_gl-ar750s-squashfs-sysupgrade.bin

You just upload the file to the file input in uboot.

I tried that and waited 5 minutes… it never reboots. I powercycle it and still does not boot up. I do a hard reset(hold button for 30 seconds after it boots up) on the router and still not booting. thinking it may be a bad build? is there a known working build?
I no longer have the ability to specifiy nor or nand in uboot since I upgraded uboot and it only gives you 1 choice to upgrade a bin in uboot. I used to have two choices. after the router reboots I cannot ping and the dhcp server is not up and running to serv up an address.

thank you for your patience and support.

my bad. for some strange reason I was loading the 750.bin instead of 750s.bin. my bad.
copied /etc/config/wireless from your gl-settings and loaded ´ath10k-firmware-qca9887´ seems to be up and running great. loaded all filess necessary for mjpg-streamer but itś not finding device /dev/video0

any ipks you can think of related to /dev/video0
also any other 750s hardware specific modules you can think of?

cannot find /dev/video0
did complete usb basic support install.
loaded usbuitls
lsusb doew not show any device, not even a thumb drive. I read that this was usb2.0 on ar750s.
I even tried usb2 pci driver
any ideas.

which video driver did you install?

You need to install something like usb-video-uvc etc.

I have setup mjpg streamer before…recently on two other vanilla openwrt routers… I have also installed the needed gspca drivers for those cameras, sonixj,sonixb,zxxxxx like my original ar150 had installled with gli-firmware. so i think iḿ okay with the setup process. yes I did install usb-video-uvc. problem is the router is not detecting any type of usb devices. in gli-firmware of ar750s the /dev/video0 device was detected but mjp-streamer failed. this error is ocurring earlier in the setup stage at the usb discovery level.

If it cannot detect any usb device then you may need to check if usb power control is disabled by GPIO.

Is this the plugin? opkg install hub-ctrl

openwrt says…
sudo ./hub-ctrl -h 3 -P 1 -p 0

That says to control hub 3 (-h 3) port 1 (-P 1) and to turn the power off (-p 0). You can also use ”-p 1” to turn the power back on

so then
sudo ./hub-ctrl -h 0 -P 0 -p 1
meaning hub zero port zero power on

No using hub-ctrl

USB power is controlled by GPIO 7 directly GL-AR750S-EXT (Slate) - GL.iNet Docs

You need to check openwrt how to set GPIO values.

looks like gpio needs to be created
/sys/kernel/debug# cat gpio
gpiochip0: GPIOs 0-31, parent: platform/18040000.gpio, 18040000.gpio:
gpio-1 ( |gl-ar750s:green:powe) out lo
gpio-2 ( |reset ) in hi
gpio-8 ( |mode ) in hi
gpio-19 ( |gl-ar750s:green:wlan) out hi
gpio-20 ( |gl-ar750s:green:wlan) out hi

and then script created in rc.common. to enable it. I can understand. itś figuring it out without doing something bad since I´ve never done this

below is output for gli firmware
gpiochip0: GPIOs 0-31, parent: platform/ath79-gpio, ath79-gpio:
gpio-1 ( |gl-ar750s:white:powe) out lo
gpio-2 ( |reset ) in hi
gpio-5 ( |sda ) in hi
gpio-7 ( |gl-ar750s:white:usbp) out hi
gpio-8 ( |right ) in lo
gpio-19 ( |gl-ar750s:white:wlan) out lo
gpio-20 ( |gl-ar750s:white:wlan) out hi
gpio-21 ( |scl ) in hi

posted in openwrt forums. waiting on 4.19 kernel, having simiilar problems with 300m and the led configs because ath79 nand support is needed. wish there was an interim fix