Mount point name issue AR750

Hi, I tried mounting my sdcard which is partitioned into 2, an ntfs and ext4. I am using the ext4 as my overlay and ntfs as my smb share. It is mounted fine and is working both with overlay and samba share.

Problem is, every reboot my mount share for both partition changes to a different mount point name, as shown in the following screenshot

On where manually mounting it manually or executing /etc/init.d/fstab boot, I am able to mount it my desired mount point name. But always change to those chars once rebooted.

This is happening even without the overlay and just mounting it in a newly reverted router image (without mounting the overlay)

Both partition have labels and I tried it multiple times. It always revert to this character mount point.

Any ideas what to change so it will not change my mount point during reboots?


I can’t tell you right because I’m using /overlay with old 512MB ext4 usb keys and 4gb ntfs sd cards on both 2 AR750 and no problem with partition labels, they never change on reboot (firmware 3.203-701 beta 4) but it is strange that you have Chinese characters, I mean in case you are not Chinese, which I do not know.

It may be that the software you have used to make partitions on your 32gb SD card is of Chinese manufacture and that software puts information in Chinese on the partition, and even if you change the label, this information is there underneath and resurfaces on every reboot.

Hi David

Thank you for your reply. Yeah seems like it is an SDCard issue, the GPT partition label is somewhat un-modifiable. Got solved when I used a sandisk card. Seems like 2 of my generic sdcard, although I am able to read, write and format it, is having issues with labeling the GPT partition for some reasons. My new sandisk sdcard doesn’t have any issues at all.

1 Like

You are welcome. :+1:t3: