MT-3000 and OpenVPN + Toggle Switch

I JUST BOUGHT the MT-3000 Travel Router and I’ve successfully configured an OpenVPN client for my Mullvad account. I have verified that it does indeed route my traffic through the node in the country I set up the OpenVPN file for.

Unfortunately when I select “Toggle Button Settings” and choose “OpenVPN Client (On/Off)” and apply it, the switch does absolutely nothing. I’ve tried going back to the VPN Client page within the router settings and disabling the client I set up… but the VPN connection only turns on & off when I toggle this software setting - it does not work with the physical toggle switch on the side of the router.

What am I doing wrong? Maybe I need to reboot? Ah yes… Rebooting after saving the setting did the trick. Please update the firmware to direct people to reboot after changing the toggle button setting in order for it to take effect.

Thank you. Solved my own issue, but still posting this so maybe you can fix this to help others

1 Like