Mt1300 beryl 5Ghz Wireless wifi issues with vanilla openwrt

So I read both wifi antenna’s were working with plain openwrt. I had seen 21.02.1 and loaded it. scans fine for 2.4ghz wireless but a 5ghz scan makes the router stop some networking services and never completes scan. I also noticed the 'switch" pulldown from ‘networking’ in luci was not there. Is that because of some of the changes to 21.x any help greatly appreciated. In the mean time I will try 21.02.0

update: tried 21.02.0 with no luck with 5gz wifi. reason i’m using this is latest testing version v3.203-oct has package installation issues. stable v3.203-aug not doing vpn policys properly for “guest network disabled for vpn”. looking for direction for a stable bin for either glinet or vanilla openwrt. looking for stable wifi and stable wireguard routing, can’t seem to get both at the same time. Using vpn Policay on ip or mac is not possible.

Cannot really help on vanilla openwrt.

But we are working firmware 3.211 which fixed some bugs of 3.203

I already tried 3.211 I have now tried 5 images to implement into a solution. 2-vanilla 3-glinet
3.211 with factory wipe yielded a default ip of instead of I always factory wipe before and after unless using gl release bins to upgrade to another release bin. I also always flash via uboot.

installing packages with snapshot fails on 2.311_1101

was really hoping I’d get to the end of this thread to good news…

so I read the post from Aug 1st here

smiled and said how nice they got both wireless working with MTK. so I ordered the mt1300. since no-one replied to the thread I guessed it was just working like every other router that works. no-where did it say “issues” with wifi in the main mt1300 wiki at openwrt like some routers do.

Same problems here ca 60 days later.

I think this is not acceptable, a product where the main functionality (at least for a travel router) is not or barely functional.

I believe it is a problem with the wireless drivers that are not opensource. Not a gli-inet problem. This is an MTK vanilla openwrt issue due to poor or limited testing on the freedevelopers part. Maybe we should demote the free developers from voluntary to slave indentured servants as an uprising? :wink:

1 Like

What are you talking about? Vanilla openwrt for MT1300 or something else?

the glinet firmware. I have another thread with details