MT1300 Router connection issues

Hi everyone,

I have a AC1300 router and since the day I got it I've had issues with getting clients connected and it seems to be getting worse with time.

Basically the clients will associate for a few seconds, then dissociate and try it all over again. After about 3 or 4 attempts, MacOS asks me for the Wifi password again.

The logs are not very helpful, but here is one of these cycles:

Sat Apr 6 20:25:17 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 IEEE 802.11: authenticated
Sat Apr 6 20:25:17 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 IEEE 802.11: associated (aid 1)
Sat Apr 6 20:25:17 2024 daemon.notice hostapd: wlan1: AP-STA-CONNECTED 52:03:29:82:fa:d1
Sat Apr 6 20:25:17 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 RADIUS: starting accounting session 86CECA8BF4046D57
Sat Apr 6 20:25:17 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 WPA: pairwise key handshake completed (RSN)
Sat Apr 6 20:25:17 2024 daemon.notice hostapd: wlan1: EAPOL-4WAY-HS-COMPLETED 52:03:29:82:fa:d1
Sat Apr 6 20:25:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPREQUEST(br-lan) 192.168.8.137 52:03:29:82:fa:d1
Sat Apr 6 20:25:18 2024 daemon.info dnsmasq-dhcp[1]: DHCPACK(br-lan) 192.168.8.137 52:03:29:82:fa:d1
Sat Apr 6 20:25:25 2024 daemon.notice hostapd: wlan1: AP-STA-DISCONNECTED 52:03:29:82:fa:d1
Sat Apr 6 20:25:26 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 IEEE 802.11: disassociated
Sat Apr 6 20:25:27 2024 daemon.info hostapd: wlan1: STA 52:03:29:82:fa:d1 IEEE 802.11: deauthenticated due to inactivity (timer DEAUTH/REMOVE)

As you can see the client is connected long enough to actually send out a DHCP request and get a response, but not longer than that. It's also obviously not a PSK issue, as the handshake is finishing just fine.

It's also important to mention that this happens with all wireless clients, Android phones, Macbooks, Windows machines, iPads etc. Sometime just power cycling the router 4 or 5 times will fix it, sometimes it won't.

And I am not sure if this is relevant, but it seems to connect to upstream wifi just fine, and if I use the wired port, everything works fine.

I am running the latest firmware (4.3.11), CPU and RAM usage seem to be reasonable and I am only using 5Ghz for my client connections (but allow both 2.4 and 5 for upstream connections), and there are no VPN or other exotic settings involved here (not even the Mac address cloning), it's mostly factory settings.

Am the only one to see this? Please help me work this out, as I would really like to use this thing when I travel, but this issue renders this thing all but useless and unreliable.

EDIT: I discovered if I reboot the thing, wait for it to come up completely, then go in an and change any settings for the 5Ghz downstream radio, and apply the settings, the thing works fine. I also think, though I am finding it hard to confirm this, that if I connect my clent to the thing before it makes the upstream connection on boot that it may work fine too.

No one? This is just me? Is there a way to get support elsewhere?

It appears I was wrong in my edit, that works completely randomly. I just changed hotels nothing I do will get this thing to work, clients connect then dissociate immediately. This time the uplink (WAN) is a wired connection.

Do I have a lemon on my hands?

What model is AC1300? A1300?It seems that your WiFi cannot connect stably

I continue to have this issue. I even did a factory reset on it. The clients continue to connect, get an IP then immediately disconnect.

It's a GL-MT1300 Beryl to be exact. (@moderators can you adjust the title of this thread please).

Is this a lemon? Or are these things just junk?

There is no AC1300

Models list
GL-MT6000 (Flint 2)

GL-XE3000 (Puli AX)

GL-X3000 (Spitz AX)

GL-MT3000 (Beryl AX)

GL-AXT1800 (Slate AX)

GL-A1300 (Slate Plus)

GL-AX1800 (Flint)

GL-MT2500/GL-MT2500A (Brume 2)

GL-SFT1200 (Opal)

GL-M2

GL-S200

GL-S10

GL-MT1300 (Beryl)

GL-M2

GL-S200

GL-S10

GL-MT1300 (Beryl)

GL-AP1300 (Cirrus)

GL-E750/GL-E750V2 (Mudi/Mudi V2)

GL-X750 (Spitz)

GL-XE300 (Puli)

GL-X300B (Collie)

GL-AR750S (Slate)

GL-B1300 (Convexa-B)

GL-S1300 (Convexa-S)

GL-MV1000 (Brume)

Run:

ubus call system board

It looks that you have fake GL device :frowning_face:

The label on the bottom says GL-MT1300, but it also says AC1300 Wireless Travel Router hence I said it was an AC1300.

root@GL-MT1300:~# ubus call system board
{
	"kernel": "5.10.176",
	"hostname": "GL-MT1300",
	"system": "MediaTek MT7621 ver:1 eco:3",
	"model": "GL.iNet GL-MT1300",
	"board_name": "glinet,gl-mt1300",
	"rootfs_type": "squashfs",
	"release": {
		"distribution": "OpenWrt",
		"version": "22.03.4",
		"revision": "r20123-38ccc47687",
		"target": "ramips/mt7621",
		"description": "OpenWrt 22.03.4 r20123-38ccc47687"
	}
}

Does that indicate it's validity?

Any suggestions on why this thing is unreliable if genuine?

I think it is client device issue.

Run:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall

HIDE PASSWORDS AND MAC

It's definitely not the client. This happens to every client I try to connect (I've tried more than a dozen different clients at this point) after I setup the upstream Wifi. They will connect, get an IP, check connectivity, then the Wifi connection just goes away and the loop starts again. Sometimes I can get it to work with several power cycles, but not always.

If there is no upstream (WAN) wifi connection, clients can connect just fine, as soon as the upstream connection is established, clients can no longer maintain that connection At that point if I hardwire a client to the router, I can get to the internet just fine and manage the device (this is how I managed to collect the logs from my first post).

Sometimes if I have a wired WAN connection it works fine, sometimes not.

The config on this thing is mostly stock, I've not customized it all since the last factory reset, other than adding an OVPN profile (this happens with or without the VPN connected) and turning off 2.4Ghz for LAN connections.

Here are the outputs of what you asked for:

/etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd3a:f9e9:5d58::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option isolate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option force_link '0'
	option ipv6 '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option disabled '1'

config interface 'tethering6'
	option ifname '@tethering'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'wwan6'
	option ifname '@wwan'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'guest'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option multicast_querier '1'
	option igmp_snooping '0'
	option isolate '0'
	option bridge_empty '1'
	option disabled '1'

config interface 'wwan'
	option proto 'dhcp'
	option metric '20'

config interface 'modem_1_1_2_6'
	option ifname '@modem_1_1_2'
	option proto 'dhcpv6'
	option disabled '1'

config rule 'policy_direct_rt'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule 'policy_default_rt_vpn'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config rule6 'policy_direct_rt6'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule6 'policy_default_rt_vpn6'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config interface 'ovpnclient'
	option proto 'ovpnclient'
	option config '89328_1'
	option disabled '1'

config device
	option name 'wan'
	option macaddr '<MAC>'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option country 'US'
	option disabled '0'
	option htmode 'HT40'
	option legacy_rates '0'
	option vendor_vht '1'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-MT1300-723'
	option encryption 'psk2'
	option key 'goodlife'
	option wds '1'
	option isolate '0'
	option ifname 'wlan0'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option band '5g'
	option country 'US'
	option disabled '0'
	option legacy_rates '0'
	option hwmode '11a'
	option channels '36,40,44,48'
	option channel '165'
	option htmode 'VHT20'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option wds '1'
	option isolate '0'
	option ifname 'wlan1'
	option ssid '<customSSID>'
	option hidden '0'
	option key '<password>'

config wifi-iface 'guest2g'
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan0-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-723-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

config wifi-iface 'guest5g'
	option device 'radio1'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan1-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-723-5G-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

/etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option rebind_protection '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option force '1'
	option dhcpv6 'disabled'
	option ra 'disabled'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config domain
	option name 'console.gl-inet.com'
	option ip '192.168.8.1'

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'disabled'
	option ra 'disabled'

/etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option flow_offloading '1'
	option flow_offloading_hw '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option input 'DROP'

config forwarding
	option src 'lan'
	option dest 'wan'
	option enabled '1'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include 'nat6'
	option path '/etc/firewall.nat6'
	option reload '1'

config rule 'block_dns'
	option name 'block_dns'
	option src '*'
	option dest_port '53'
	option target 'REJECT'
	option device 'br-*'
	option enabled '0'

config include 'gls2s'
	option type 'script'
	option path '/var/etc/gls2s.include'
	option reload '1'

config include 'glblock'
	option type 'script'
	option path '/usr/bin/gl_block.sh'
	option reload '1'

config zone
	option name 'guest'
	option network 'guest'
	option forward 'REJECT'
	option output 'ACCEPT'
	option input 'REJECT'

config forwarding
	option src 'guest'
	option dest 'wan'
	option enabled '1'

config rule
	option name 'Allow-DHCP'
	option src 'guest'
	option target 'ACCEPT'
	option proto 'udp'
	option dest_port '67-68'

config rule
	option name 'Allow-DNS'
	option src 'guest'
	option target 'ACCEPT'
	option proto 'tcp udp'
	option dest_port '53'

config include 'vpn_server_policy'
	option type 'script'
	option path '/etc/firewall.vpn_server_policy.sh'
	option reload '1'
	option enabled '1'

config zone 'ovpnclient'
	option name 'ovpnclient'
	option forward 'DROP'
	option output 'ACCEPT'
	option mtu_fix '1'
	option network 'ovpnclient'
	option input 'DROP'
	option masq '1'
	option masq6 '1'
	option enabled '0'

config forwarding 'ovpnclient2wan'
	option src 'ovpnclient'
	option dest 'wan'
	option enabled '0'

config forwarding 'lan2ovpnclient'
	option src 'lan'
	option dest 'ovpnclient'
	option enabled '0'

config forwarding 'guest2ovpnclient'
	option src 'guest'
	option dest 'ovpnclient'
	option enabled '0'

The previous post was when there was no upstreak Wireless WAN (clients connect fine). Here are the same logs, with this time connected to the upstream, with the issue happening.

Another thing to note is that this happens with any upstream Wifi that I have tried (several hotel and other places at this point)

cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option packet_steering '1'
	option ula_prefix 'fd3a:f9e9:5d58::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'
	list ports 'lan2'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.8.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option isolate '0'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'
	option force_link '0'
	option ipv6 '0'

config interface 'wan6'
	option proto 'dhcpv6'
	option ifname '@wan'
	option disabled '1'

config interface 'tethering6'
	option ifname '@tethering'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'wwan6'
	option ifname '@wwan'
	option proto 'dhcpv6'
	option disabled '1'

config interface 'guest'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option ipaddr '192.168.9.1'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option multicast_querier '1'
	option igmp_snooping '0'
	option isolate '0'
	option bridge_empty '1'
	option disabled '1'

config interface 'wwan'
	option proto 'dhcp'
	option metric '20'

config interface 'modem_1_1_2_6'
	option ifname '@modem_1_1_2'
	option proto 'dhcpv6'
	option disabled '1'

config rule 'policy_direct_rt'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule 'policy_default_rt_vpn'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config rule6 'policy_direct_rt6'
	option lookup 'main'
	option suppress_prefixlength '0'
	option priority '1100'

config rule6 'policy_default_rt_vpn6'
	option mark '0x8000/0xc000'
	option lookup '8000'
	option priority '1101'
	option invert '1'

config interface 'ovpnclient'
	option proto 'ovpnclient'
	option config '89328_1'
	option disabled '1'

config device
	option name 'wan'
	option macaddr 'DA:6A:01:DA:CA:51'

cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option band '2g'
	option country 'US'
	option disabled '0'
	option htmode 'HT40'
	option legacy_rates '0'
	option vendor_vht '1'
	option channel '6'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'GL-MT1300-723'
	option encryption 'psk2'
	option key 'goodlife'
	option wds '1'
	option isolate '0'
	option ifname 'wlan0'
	option disabled '1'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0+1'
	option band '5g'
	option country 'US'
	option disabled '0'
	option legacy_rates '0'
	option hwmode '11a'
	option channels '36,40,44,48'
	option channel '165'
	option htmode 'VHT20'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2'
	option wds '1'
	option isolate '0'
	option ifname 'wlan1'
	option ssid '<customSSID>'
	option hidden '0'
	option key '<password>'

config wifi-iface 'guest2g'
	option device 'radio0'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan0-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-723-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

config wifi-iface 'guest5g'
	option device 'radio1'
	option network 'guest'
	option mode 'ap'
	option ifname 'wlan1-1'
	option encryption 'psk2'
	option key 'goodlife'
	option ssid 'GL-MT1300-723-5G-Guest'
	option guest '1'
	option disabled '1'
	option wds '1'
	option isolate '1'

config wifi-iface 'sta'
	option mode 'sta'
	option device 'radio0'
	option network 'wwan'
	option ssid 'RiverBendWireless'
	option bssid '7E:8A:20:24:9A:49'
	option macaddr 'DA:6A:01:DA:CA:51'
	option encryption 'none'
	option ifname 'wlan-sta0'

cat /etc/config/dhcp

config dnsmasq
	option domainneeded '1'
	option boguspriv '1'
	option filterwin2k '0'
	option localise_queries '1'
	option rebind_localhost '1'
	option local '/lan/'
	option domain 'lan'
	option expandhosts '1'
	option nonegcache '0'
	option authoritative '1'
	option readethers '1'
	option leasefile '/tmp/dhcp.leases'
	option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
	option nonwildcard '1'
	option localservice '1'
	option ednspacket_max '1232'
	option rebind_protection '0'

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv4 'server'
	option ra_slaac '1'
	list ra_flags 'managed-config'
	list ra_flags 'other-config'
	option force '1'
	option dhcpv6 'disabled'
	option ra 'disabled'

config dhcp 'wan'
	option interface 'wan'
	option ignore '1'

config odhcpd 'odhcpd'
	option maindhcp '0'
	option leasefile '/tmp/hosts/odhcpd'
	option leasetrigger '/usr/sbin/odhcpd-update'
	option loglevel '4'

config domain
	option name 'console.gl-inet.com'
	option ip '192.168.8.1'

config dhcp 'guest'
	option interface 'guest'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option dhcpv6 'disabled'
	option ra 'disabled'

cat /etc/config/firewall

config defaults
	option syn_flood '1'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'REJECT'
	option flow_offloading '1'
	option flow_offloading_hw '1'

config zone
	option name 'lan'
	list network 'lan'
	option input 'ACCEPT'
	option output 'ACCEPT'
	option forward 'ACCEPT'

config zone
	option name 'wan'
	list network 'wan'
	list network 'wan6'
	list network 'wwan'
	option output 'ACCEPT'
	option forward 'REJECT'
	option masq '1'
	option mtu_fix '1'
	option input 'DROP'

config forwarding
	option src 'lan'
	option dest 'wan'
	option enabled '1'

config rule
	option name 'Allow-DHCP-Renew'
	option src 'wan'
	option proto 'udp'
	option dest_port '68'
	option target 'ACCEPT'
	option family 'ipv4'

config rule
	option name 'Allow-IGMP'
	option src 'wan'
	option proto 'igmp'
	option family 'ipv4'
	option target 'ACCEPT'

config rule
	option name 'Allow-DHCPv6'
	option src 'wan'
	option proto 'udp'
	option dest_port '546'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-MLD'
	option src 'wan'
	option proto 'icmp'
	option src_ip 'fe80::/10'
	list icmp_type '130/0'
	list icmp_type '131/0'
	list icmp_type '132/0'
	list icmp_type '143/0'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Input'
	option src 'wan'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	list icmp_type 'router-solicitation'
	list icmp_type 'neighbour-solicitation'
	list icmp_type 'router-advertisement'
	list icmp_type 'neighbour-advertisement'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-ICMPv6-Forward'
	option src 'wan'
	option dest '*'
	option proto 'icmp'
	list icmp_type 'echo-request'
	list icmp_type 'echo-reply'
	list icmp_type 'destination-unreachable'
	list icmp_type 'packet-too-big'
	list icmp_type 'time-exceeded'
	list icmp_type 'bad-header'
	list icmp_type 'unknown-header-type'
	option limit '1000/sec'
	option family 'ipv6'
	option target 'ACCEPT'

config rule
	option name 'Allow-IPSec-ESP'
	option src 'wan'
	option dest 'lan'
	option proto 'esp'
	option target 'ACCEPT'

config rule
	option name 'Allow-ISAKMP'
	option src 'wan'
	option dest 'lan'
	option dest_port '500'
	option proto 'udp'
	option target 'ACCEPT'

config include 'nat6'
	option path '/etc/firewall.nat6'
	option reload '1'

config rule 'block_dns'
	option name 'block_dns'
	option src '*'
	option dest_port '53'
	option target 'REJECT'
	option device 'br-*'
	option enabled '0'

config include 'gls2s'
	option type 'script'
	option path '/var/etc/gls2s.include'
	option reload '1'

config include 'glblock'
	option type 'script'
	option path '/usr/bin/gl_block.sh'
	option reload '1'

config zone
	option name 'guest'
	option network 'guest'
	option forward 'REJECT'
	option output 'ACCEPT'
	option input 'REJECT'

config forwarding
	option src 'guest'
	option dest 'wan'
	option enabled '1'

config rule
	option name 'Allow-DHCP'
	option src 'guest'
	option target 'ACCEPT'
	option proto 'udp'
	option dest_port '67-68'

config rule
	option name 'Allow-DNS'
	option src 'guest'
	option target 'ACCEPT'
	option proto 'tcp udp'
	option dest_port '53'

config include 'vpn_server_policy'
	option type 'script'
	option path '/etc/firewall.vpn_server_policy.sh'
	option reload '1'
	option enabled '1'

config zone 'ovpnclient'
	option name 'ovpnclient'
	option forward 'DROP'
	option output 'ACCEPT'
	option mtu_fix '1'
	option network 'ovpnclient'
	option input 'DROP'
	option masq '1'
	option masq6 '1'
	option enabled '0'

config forwarding 'ovpnclient2wan'
	option src 'ovpnclient'
	option dest 'wan'
	option enabled '0'

config forwarding 'lan2ovpnclient'
	option src 'lan'
	option dest 'ovpnclient'
	option enabled '0'

config forwarding 'guest2ovpnclient'
	option src 'guest'
	option dest 'ovpnclient'
	option enabled '0'

So strange… All configs fine. Maybe it is system bug. Try to flash new firmware.

Guide and firmware.

DOUBLE CHECK MODEL!

Anyway, if this won’t help, you should contact support. Or tag @alzhao. But I hope flash will help.

@Bruce Maybe you can have a look into this issue?

This was actually the first thing I did when I ran into this (well when I got home), followed by a factory reset. I'll check to see if there is a newer FW now, and see if that makes a difference.

@alzhao and @Bruce - Any suggestions?

Sorry for late reply.

I checked the config. The router is using 2.4G to talk to upstream wifi. It should not affect its 5G AP. But as you said it will have problems when using as repeater, but not have problem when not using as repeater, the log and config may not said everything.

I think you can try using a different power adapter. If not solving, can you write to us via email support at glinet.biz

We may ask for some updated log and config.

Thanks, I did not think about trying this and it could be the issue. I am using a 5V 3A charger, that I thought was an Apple USB C charger, but it looks to be more generic (though it feels solid). Regardless, I have ordered a Ugreen 30W charger to test with.

I'll report back next week when I've had the chance to test it.

1 Like

Nope, new power adapter and high quality USB cable has not resolved the issue. I bought a UGreen 30W power adapter and one of their USB C cables.

@alzhao What do you need from me to work on this? So far this device has not worked well for me from day one, almost all the settings are stock. Very very frustrated with this and the entire experience.

EDIT: One thing to note that my Pixel 8 Pro will now connect, get an IP and hold the connection for maybe 5 seconds, then it just drops and I am back on 5G.

Either I have a lemon that is just plain defective here, or this product is just not that great. Due to the overall popularity of these things I am inclined to believe its the former, in which case how can I get this thing back to you and get a replacement?

I checked your config again. You are repeating a wifi with channel 165. Although the config seems correct but I met a problem in my side when doing the same thing.

I suggest that you do this:

  1. If you have control of your parent router, pls change channel to 36-48, 149-161.
  2. Pls also change the wifi channel of the router itself to the above channels. As you don't have repeater, pls change it to common channels.
  3. Do a reset of the router. Do not turn off 2.4G. Not sure why you do this. When you have problem with repeater on 5G, just connect to 2.4G and get the log. Only the first post contains some logs.