MT2500 freeze with usb Ethernet adapter

I have a Brume2 and I would like to add a usb Ethernet adapter as second WAN.

I tried 3 differente usb Ethernet adapter:
RTL8153
LAN7500 - smsc
Asix

If I connect the adapter without installing the driver, brume2 works but obviously I don’t see the eth2. Every time I install the driver and the adapter is connected, brume 2 freeze and remain freezed even if I disconnect and reconnect the USB-C power.

I read somewhere tha usb adapter should work, do you think it’s a problem of the last firmware?

If you figure it out, let me know. I'd like to add a 2.5gb USB to Ethernet adapter.

1 Like

Downgraded to 4.4.6 and now it works, I will try to upgrade 4.5.0 and see what happen

edit:

  • 4.5.0 Works and i able to do tether on eth2
  • 4.5.16 Doesn't work

Strange thing, packages are the sames version

Do you have kernel log? Seems there is a crash.

@alzhaho Where are the logs? Logs are stored after a reboot?

Unfotunately you have to get the log before reboot. If it is not responsive at all then that is a problem.

If you don't mind pls try 4.6.0 beta which is released today.

Device completely freezed, I need to remove usb adapter and then power off and power on.
Where can I find the beta firmware?
On the "snapshot section" of "firmware download center"?

https://dl.gl-inet.com/router/mt2500/

Sorry it is a snapshot.

I installed now the 4.6.0 snapshot, same behaviour as soon as I install the adapter driver, with adapter connected, the device crash.
I noticed this:

  • Adapter connected: I'm unable to install package, opkg gives me this message
root@GL-MT2500:~# opkg install kmod-usb-net-asix-ax88179
Installing kmod-usb-net-asix-ax88179 (5.4.211-1) to root...
Downloading https://fw.gl-inet.com/releases/v21.02.3/kmod-4.2.1/aarch64_cortex-a53/mediatek/mt7981/kmod-usb-net-asix-ax88179_5.4.211-1_aarch64_cortex-a53.ipk
Installing kmod-libphy (5.4.211-1) to root...
Downloading https://fw.gl-inet.com/releases/v21.02.3/kmod-4.2.1/aarch64_cortex-a53/mediatek/mt7981/kmod-libphy_5.4.211-1_aarch64_cortex-a53.ipk
Configuring kmod-libphy.
client_loop: send disconnect: Connection reset

Then ssh is disconnected

  • Adapter not connected: I'm able to install the package but once adapter is connected the device freeze

I will let guys check. Seems there is a kernel module mismatch or something.

1 Like

Are all three adapters has problems? We tried one and didn't freeze.

What adapter did you try?

In my case all three adapters have problems with 4.5.16:

  • asix88179 USBA - kmod-usb-net-asix-ax88179
  • smsc75xx USBA - kmod-usb-net-smsc75xx
  • RTL8153 - kmod-usb-net-rtl8152 with USB-C (USB-A USB-C adapter)