MT2500 LAN port

I’ve the MT2500 with WAN connected to a modem in bridge mode to get a public IP address. When I connect my laptop on the LAN port ( the laptop don’t get an IP.
Tried to restart the LAN interface via luci nothing happened. The only way the laptop get an IP is to reboot the MT2500.
Is this an familiar issue or a bug in the fw version 4.2.0 snapshot?

Thanks for your feedback.
Does the MT2500 use PPPoE? Did you experience similar problems with previous firmware versions?

Did you set up in network->network mode->bridge?

No, the MT2500 get a dynamic IP from the modem (DHCP).
Now that I upgraded to fw 4.2.0 snapshot I noticed this, Tried to roll back to fw 4.1.1 to check it out but when restoring the backup file I don’t get all views when log in the admin panel.
Forced to upgrade to 4.2 again and restore the backup. Still need to reboot the MT2500 for the laptop to get an IP address.

No, the MT2500 get a dynamic IP (DHCP) from the ISP modem which is in bridge mode.

Issue is resolved with the snapshot fw 4.2.0 compiled 2022-12-26

1 Like