[MT300] TTL override doesn't work in 4.5.0

I tried a few release, and confirmed that both 4.5.0 and 4.5.16 don’t support TTL overwrite. I have to switch back to 4.4.6.
In the release note of 4.5.0, there is

Bug fixes

  • Fixed an issue with the TTL settings not taking effect.

Is this a known issue?

How do you set up the ttl?
On which function is it set?
Do you have any screenshots?

Thanks for your reply.
I added following

iptables -t mangle -I POSTROUTING 1 -o usb0 -j TTL --ttl-set 65
# iptables -t mangle -I POSTROUTING 1  -j TTL --ttl-set 65

to /etc/firewall.user hoping to bypass the throttle of tethering.
The stock firmware was 4.4.5 and changing TTL can bypass the throttle. I then upgraded the firmware a few times and that override only works for 4.4.6.

I don’t have screenshots, but I test the internet speed each time. When throttled, it only has ~0.6Mb/s; with TTL overwritten, the speed could be >100Mb/s.

Try installing iptables-mod-ipopt

Thank you.
I just upgraded to 4.5.16 via Online Upgrade and install iptables-mod-ipopt. However, my phone plan hasn’t exhausted hotpot plan, so I cannot tell whether it works now.
Do you have suggestions how to check the TTL of outgoing packet? Thanks.

Another question: after upgrade with “keep settings”. I noticed that files under /etc/init.d/ and /usr/bin/ are reset. Is this by design.

Sorry if those are newbie questions. I am new to these. Is there a beginner FAQ list I can read?


As far as I know, the keep settings is only for settings about the OpenWrt base system, so config files, no binaries or custom scripts. You can add paths, you would like to keep during update, to /etc/sysupgrade.conf

1 Like

Please execute the iptables command again, if there is no error it means that it was added successfully

Thanks. Also confirm it works after burning more data than my hotspot plan today!

How to fix bro? My mt3000 same ttl not working

and re-execute your TTL override

thank bro ... it worked