MT3000 2.4GHz network Disappearing

Update :

I have experienced the same issues I was claiming before but now I have found the culprit.
In first tests I have stupidly forgot to mention that I also had a USB3.0 Stick connected to the router. A decent USB stick from San Disk 32GB link here .
After I have updated to fw 4.2.0 beta 2 I have not connected the usb stick to the router.
All my tests after the update were without the usb stick and jus tnow I have plugged the USB stick and the entire network became unstable. The 5GHz SSID was appearing and disappearing and the 2.4GHz SSID associated IoT devices started to connect and disconnect. I have removed the USB stick after a few minutes and immediately the router returned to normal. I have attached here the kernel leg between plugging the USB stick and disconnecting the usb stick. It ended up being a 24page long log so whoever will read it will need a beer or a coffee :slight_smile:

kernel log usb (90.1 KB)

1 Like

Thanks for your feedback. We will check it.
Also may I ask, are you using the power adapter that came with MT3000?

I am using a different adapter as I need a longer power cable.
I use this power adapter with a 2m cable that is 100W emarked and tested to carry up to 100w. So basically the power shouldn’t be an issue unless the router has difficulty to handle the PD standard but as it powers up when connected to the emarked cable, I assume the implementation of the PD standard is good or it is using 5.1k resistors on the PD line which will give it 5V and 3A .


Software version 4.4.5
a few days ago everything was ok. Today I wanted to scan the list of available wifi networks and it doesn’t find any one. When adding a Wi-Fi network manually, I also cannot connect. I decided to restore the factory settings, after logging in again there was still no wifi available.
I have a Mudi 750 router turned on next to it, so I can see many networks available. On the mt3000, none of them.
What could be the reason?

Not even one?

Is the wifi of MT3000 itself OK?

I checked everything again today.
I have two rutets next to each other
MUDI 750 and the are a lot of available networks - everything is OK.

Below are screenshot from MT3000 (connected via LAN cable) with the current software version is 4.4.5 compile time 2023-08-11

Picture shows list of detected networks → none .On the same screen is a window from computer’s Wi-Fi card, you can see many available networks.

You can also see the available network of the MT3000 itself
also after entering the network manually, i cannot connect.

I can send the logs but I need to know which ones.

I also attached screen how looks like list of MUDI 750 in the same time

Can you reset the firmware and try again?

I tested mine and it works OK. So may be a problem brought up during upgrade.

I did it. Reset the firmware . After that:

  1. I set admin password.
  2. check upgrades now have stil software version 4.4.5
  3. Search wifi and the result is still the same. No list with wifi
    have some informationa about EAP - dont know exacly whati is it.

also have such defoult options

Any idea to help me? Or maybe it is a phisical problem so i can retutn this device and get another one?

Can you contact us via email: support at

Want to do a remote check using anydesk?