MT3000 firmware 4.5 latest Beta issue


You might not be looking for feedback on snapshots, but I wanted to report an issue that’s been present for over a week, in case it’s gone unnoticed.

After updating to latest snapshot without keeping settings, 5G AP comes up with SSID “MTK_CHEETAH_AP_5G”

After configuring it and changing SSID, after boot it will still come up with SSID “MTK_CHEETAH_AP_5G”. While ON, restarting networking will make it come up with the configured SSID.

Let me know if this issue doesn’t occur on your end and if you need logs.

Thank you!

Just noticed a Beta version of 4.5 dated November 13 has been posted, of course went ahead and installed it (no settings retention).

When coming up 5G AP is properly named “GL-MT3000-xxx-5G”

Going to, setting English as language then setting an Admin Password and then rebooting, 5G AP comes up as “MTK_CHEETAH_AP_5G”

Went to Admin panel and reset the configuration and tested the same process 5 times, always same result.

How can this BASIC FUNCTIONALITY go undetected at Beta level release?

@alzhao Not sure if you read the forums, hardware devices may be good, but firmware management is a joke !!

1 Like

If it’s not clear where the problem is, if I change 5G SSID name and set an AP password and reboot, the 5G AP will come up as open network named “MTK_CHEETAH_AP_5G”.

Now imagine I also have a VPN configured to connect to my private data vault…

1 Like

OK. So it is stupid bug then.

Same here. Upgraded to 4.5 beta and no 5g network displayed apart from “Mtk_Cheetah_ap_5g”. I did keep previous settings. I was a beta tester for this model and have upgraded to each beta release as they have been published and this is the first instance of this issue I have seen. No such issue with 4.5 on Slate AX or Flint so chipset related?

1 Like

Still no fixes? The MT3000 is still kind of messy. Version 4.5 does fix some issues, but this bug makes it unusable.

Old firmware versions are too buggy.

There’s no snapshot history available for downloading a pre-bug version 4.5.

We are in limbo!


Sorry we do have the firmware. Will push on the website now.

1 Like

Great news @alzhao !!

Thank you for posting 4.5 Beta Release 4 , at first, it seams to have resolved the issue!

Good job!

1 Like

And that’s a Thank You from me too!

1 Like

Running 4.4.6 here (just updated from 4.4.5) - I also noticed this same issue with Cheetah APs appearing at boot then eventually disappearing once boot process has finished. So not sure it was introduced in the latest beta, seems to have been around prior? Fingers crossed that’s it now fixed?


They are the default configuration of the MTK WiFi driver, and they are used during the driver startup process, and then immediately overwritten by the SSIDs we configured.