MT3000 in Hotel no connect

i try it, nothing changes

Does the router see getting IP address?

I have a new firmware and can send you to try this week.

Hello,

No it becomes no ip, the message is the router wait fot it.

Please send it to me the new firmware,

Thank you ...

Can you try this one?

If have problems pls reset the settings.

3 Likes

Ok, thank you.

But is this firmware completely new, i have download it from the homepage.

Is that a newer release as the homepage ?

I just tried this firmware.

  1. This firmware made the wifi connection to the router very unstable. My laptop was constantly disconnected.
  2. When i tried to connect to a wifi the router found none - while there are 72 (sitting at the airport in Düsseldorf).
    For the moment i am back to latest snapshot.
    Will check the log now for something.

logread.tar (181.5 KB)

1 Like

Did you keep settings?

Yes. Because it was from 4.6 snapshot to another 4.6.
Should I try with factory reset.

hello, i have use the firmware and it works. I have reset completly.

The WiFi is stable, but i ihave changed my internal GliNet LAN Network adress but it is the same with the hotel router, but that is not a problem.

What is the different àt the firmware how it works right now

2 Likes

If someone uses this router as a traveler, I think that after changing the software, it is worth restoring the router to factory settings or updating it without keeping the settings.

This is a firmware built using opensource wifi driver using latest openwrt version.

2 Likes

@alzhao is there a timeline for either getting the wifi drivers into the GLiNET FW or for using this openwrt as the basis for the formal GLiNET FW?

Whilst this adds functionality (that it appears the GLiNET FW lacks) and for some, stability, what current GLINET functionality does this openwrt FW lack please if any?

The openwrt 24 firmware goes to normal release schedule. So hopefully it will be stable as well.
https://dl.gl-inet.com/router/mt3000/

1 Like

Using my new GL-MT3000 for the first time at a hotel, I had no issues setting it up and logging in via captive portal. However, a few days later while still at the same hotel, a storm came and the hotel experienced a power failure. After power was restored, I could no longer reconnect with the MT-3000, but had no issues connecting from my iPhone and laptop directly to the hotel’s WiFi without using the travel router. I could no longer get access to the captive portal from the MT-3000 using Safari on my iPhone in order to re-establish connectivity. I even tried resetting the travel router to factory settings to no avail. But then I finally got the captive portal page to pop up only after enabling and then disabling AdGuard from my iPhone using the Safari browser! I had never ever before enabled and used AdGuard! Now I’m a happy user and traveler. Very strange.

Firmware version: 4.5.16
Firmware Type: release3

1 Like

Seems the Adguard breaks the portal. The portal use a local domain and may be blocked by Adguard.

By default, shouldn't Adguard be turned off and disabled after the router was reset to factory settings?

Yep, any situation of restore/reset to default, it definitely to disable/off the ADG, as default settings is disabled. Probably did execute the restore settings not successful, or the process has been broken.

A few things to also try when you have the issue of not getting the captive portal. I travel every week and one of the following usually solves the problem.

  1. Make sure VPN is off, sometimes when I leave the hotel I leave the VPN on and then when going back on another trip it won't connect as it is also trying to activate the VPN at the same time.

  2. Make sure adguard is off, I've had various issues with adguard at hotels, but at some hotel chains you literally can't connect to the portal when adguard is on.

  3. try to see if the hotel has a default page that will force the portal. For example the Marriot I stay at, I can always hit "www.marriottwifi.com" and that takes me to the portal to connect.

  4. if trying from a windows PC, try this url "www.msftconnecttest.com/redirect" as sometimes it will force the portal to appear

  5. If you are connecting to the GL Inet device wirelessly, forget the wireless network on the device you are trying to connect with then re-add it and put in the security key. Sometimes just doing this will force the portal to appear on the device after reconnect.

  6. Lastly on some older firmware, a factory reset of the GL Inet device would allow me to connect. I haven't had this problem with the newer firmware though.

Hope this helps.

1 Like