MT3000 minor problem (or bug) using WiFi mode "n"

I have an old computer that only supports (up to) the “n” WiFi mode.
This computer can only connect to my Beryl MT3000 when the mode is set to “a/n/ac” (5GHz) or “b/g/n” (2.4GHz). None of the other options (i.e., ones that include both “ax” and “n”) work. I don’t know if this is just my computer (a Dell E7250) or if it occurs in other older computers too.
This should be fixed by (1) changing the drop-down option descriptions, (2) fixing the code, or (3) warning that some WiFi cards might not work with options containing “ax”.