MT3000 wifi not working after FW 4.2.2 upgrade

Dear GL iNet team,

I have just bought a MT3000 router since last month and everything works well until the recently firmware upgrade from 4.2.1 to 4.2.2. After I’ve got the upgrade notification from WebAdmin and accept, then complete and reboot the router, the wifi function doesn’t work anymore.

Every features related to wifi, include repeater, wifi access point are now not working. My laptop, phone doesn’t see wifi network broadcasting from MT3000. In repeater mode, MT3000 cannot detect any wifi networks nearby to connect to.

I also tried to downgrade to 4.2.1 firmware and even tried some beta, snapshot firmware version but still no help. It seems to be the problem related to a hardware or drivers problem because in the Wifi setting page, the bitrate number is smaller then it should be for MT3000.

Please help me with this issue. I were quite happy with this router before this issue. (Note: I stay in other country, and bought this router from China taobao site.)

What are your Wi-Fi Mode and Bandwidth settings? Please try to select the ax mode and 160MHz.
Please note that the VPN feature is not available for products purchased in China.

The mode is ax right now and banwidth is 80MHz for 5.0GHz. I don’t think it could be a problem because I keep it like that at the first time but I will give it a try.

Try downloading the actual .TAR file form GL.iNet download page and load it manually. I think somehow you got the MT2500 Firmware. I am running a snapshot from 4-20-23 and seems to be working fine. Did you keep settings when you upgraded?

Could also be the channel and bandwidth is congested

Thanks for the suggestion but I did many times of firmware reflash (without keeping settings), the firmware is downloaded from GL.iNet and be sure for MT3000. In my troubleshooting, it is likely that the MTK hardware (or driver) is now not working anymore.

Can you export and send the log? If wifi has issues, the log will display some errors. (13.7 KB)

Hi @alzhao,

I attached the log, please help to check.

The system log is fulled up with some error messages. Don’t know what is that be definately wifi has errors.

Have you tried to reset the firmware?

Many actions what I can think about have been done:

  • Re-upgrade v4.2.2, downgrade firmware to v4.2.1, without keep settings, from both WebAdmin and uboot
  • Reset firmware as you said

How about this, first increase the log size

uci set system.@system[0].buffersize=204800 
uci set system.@system[0].log_size=600   
uci commit

Then reboot the router, check the log and it should contains much useful log. Pls send to me again.

Yes, this time is a bigger log file. From the beginning of the log, there are some more information. (52.7 KB)

The log is still does not contain from the beginning. Seems the error appear too quick.

If you have flashed the firmware and reseted, seem that it has problem in radio data or hardware.

Can you send back the device to me to check?

This may sound strange, but my MT3000 with 4.2.2 release 2 also wasn’t connecting in repeater mode to an Ubiquiti router and I fixed it by setting a random Mac address. Sometimes I had to try a couple of different ones until it finally did the trick.

Can you try and let us know if it helps?

1 Like