MT300A as Openvpn Server


#1

I currently have a MT300A in router mode acting as a Open VPN server - it is connected via the WAN port and ethernet cable to my network with a static ip address of 192.168.0.53.

I can to connect to my local network and internet OK via Wifi on the MT300A - it is also provides a good OpenVPN server from the outside world.

However I can only connect to the MT300A configuration page itself on 192.168.8.1 directly via Wi-Fi or the LAN port - I would like to be able to connect to it on the address 192.168.0.53 so I can configure the unit when using the OpenVPN connection.

I’ve tried configuring the MT300A as an AP but the OpenVPN function is then unavailable.

Any suggestions please ?

Also when we will be able to select more advanced OpenVPN parameters like TLS-Auth key when configuring the OpenVPN server ?

Many thanks,

Pseudonoise


#2

Are you using 3.x firmware or 2.x firmware?

3.x firmware can be found here https://dl.gl-inet.com/firmware/mt300a/testing/

Yes you can change Openvpn parameters but only manually. You can find the config in /etc/openvpn and feel free to modify.

If you want to access the router from WAN side, you may need to open port in Luci. You also can enable WAN access in 2.x firmware or enable DDNS in 3.x firmware.

Check 3.x DDNS docs here
https://docs.gl-inet.com/en/3/app/ddns/


#3

Thanks Alzhao - I tried opening the port in Luci so I could see the router on the local network on 192.168.8.1.

I must have done something stupid as I “broke” the router and caused multiple problems on the local network (my IPTV stopped working). I’ve just factory reset the MT300A and would like another go.

Could you please provide a bit more advice on what and where I should change in Luci

Thanks again for your support - it is much appreciated.

Pseudonoise


#4

Ok, seems I missed the simple method.

In firmware 2.x just go to Access page and enable “wan access”. Then your router can be accessed via 192.168.0.53:83

Anyway I suggest you try firmware v3.x. Pls download and try here https://dl.gl-inet.com/firmware/mt300a/testing/


#5

Thanks Alzhao
I’m already using 3.013 testing firmware what is the correct way to enable WAN access on the 3 series firmware ?


#6

You need this

https://docs.gl-inet.com/en/3/app/ddns/