MT300A Reverts to Defaults every reboot

As the title says, anything I change on this router is lost on a reboot (either hard or soft). Upon logging in the device presents me with the logon screen. I just received the unit upgraded the firmware and to the latest.

It doesn’t matter if I change something from the gl.inet gui or openwrt gui.

Thanks for any assistance.


What are you powering it with?

Same issue here ! I recently purchased the router (AR300M) via Amazon Germany and tried it out today for the first time. I´m powering the device with an Anker 2.1 Ampere USB Power Supply using the original USB-Cable that came with the router. Any further ideas or should I return the router to the seller ?

Have you tried a cold boot failsafe recovery?

Failsafe mode


To enter Failsafe mode you need to press reset button repeatedly until LAN LED starts blinking very fast.



No I didn’t - in the meantime I was able to resolve the issue by myself by changing the root PW in ‘advanced Settings’ and hitting ‘save and apply’. After reboot, the router showed the login screen without asking for first time setup and the device works like a charm. Maybe that helps for sjgieson as well ?

It appears flashing again with unchecking keep settings option resolved the issue. When I updated the firmware I left that checked the first time. I tried multiple power supplies btw, all were between 1 and 2+ amps.


Thanks for the idea about the advanced settings, i fixed before I saw this post but if it happens next time I will give that a go.

If it revert to the default setting for the first time, it means the filesystem cannot be built for some reason. This can be a problem if you install too many packages and flash is full.

If this happens, ssh (or telnet) to the router after it boot. Then type “firstboot” and answer yes. Then type reboot to reboot the device.

Thanks, I will give that a try next time.


I’ve discovered and purchased this router last weekend. Absolutely great product for travelling! ??

It already came with 2.25 in, but I can confirm the issue. Initially configured it yesterday evening, put my ovpn files in, working great. This morning when I plugged it in again all was gone and I was greeted with the initial settings screen again.

Tried this one more time, still the same. Then I found this thread and what KingKongKlaus wrote worked for me. Once you initially save one time in Luci, the problem is gone and afterwards the router also saves in the GLI GUI. Seems to be a glitch in the firmware.

@netmax and @sjgieson,

I currently don’t know what is the reason because nobody reported such problem in MT300A before. This could only happen when the flash is full if you use opkg to install too many packages.

@KingKongKlaus use AR300M which is a different device because it has a Nand flash. The nand flash cache data and will not write immediately by default. So if you configure and reboot immediately the config is lost. But we fixed this by call sync to let the flash save immediately in v2.25 and this should not be there. After you change something if you let the router be powered on for more than 10 minutes the cache should also be saved as well.

I have no idea how this is related to Luci.

If you could feedback more information that could be very helpful.

@alzhao: Sorry for confusion, but I’m also talking about the AR300M. Firmware 2.25 on the box at arrival, no additional packages. Configured first time and it was powered for 4h after that.

It showed the initial 3 screens after reboot every time and the settings are defaulted until I saved one time in Luci, now anything is fine