MT300N - DHCP unable to resolve on Lan

I’m using An ASUS ac68u as my primary router; I bought the GL.iNet to extend my lan; Plugging in the cable into LAN shows a red led on GL.iNet device. Updated to the latest firmware. Both basic and advanced settings show dhcp is not resolving. Static IP does not work either. Other routers and devices resolve perfectly. How do I fix this?

Assuming you’re referring to obtaining an IP address (as compared to DNS resolving), the GL internal DHCP server is probably conflicting with the DHCP server on the Asus router.

I haven’t set up this configuration on my GL device before, though I have for other devices. I’d imagine you can plug it directly in to your computer (or connect directly to it via WiFi without it being plugged into your Asus router) to configure it to act as a wireless gateway for an existing router, rather than as a router itself. This would then disable the built-in DHCP server.

You would find this under the advanced settings (upper right corner) then Network > DHCP & DNS and turn off “Authoritative”.

As I haven’t done this config before on these devices, someone else will surely chime in if I’ve got this wrong.

1 Like

Thank you so much for your response; I certainly will consider doing this; There is also an option under advanced which states something to the effect of “this is not the only dhcp server on the lan” which will probably help to avoid conflicts; I have checked this off; Also, I have managed to successfully resolve my DHCP, I was plugging my GLI into the lan rather than the wan port; that was my problem/mistake.

If I disable DHCP server, will I still be able to access the web menu for the GLI? I cannot access it now anyway; I have a switch routing my internet connection to my PC and the GLI; I can’t connect to the GLI unless I’m plugged directly into the device… or over my phone but that is very inconvenient. Any ideas?

Running XARP (which detects all devices on a network) it cannot locate any gli ip’s. only those which were assigned by the dhcp on asus.

  1. When the GL device’s DHCP server is disabled, then it should work when connected to the LAN port. You’ll need to access the GL device’s admin settings using whatever IP address it receives from the Asus router OR statically configure the GL IP to be something in the Asus router’s range. For example if it uses, then make your GL device (assuming .20 is outside of the Asus’s DHCP range)
  2. If you’re connecting the primary router to the WAN port, then you’ll want to use the advanced settings to reconfigure the WAN port to be part of your LAN instead (though then you’ll still need disable DHCP authoritative mode). Otherwise you end up double NAT’d where your Asus router has one IP range and your GL device is yet another segregated ‘network’ down the tree with its own IP range.

It’s probably simpler to just use the LAN port without the authoritative DHCP server on the GL, unless you happen to want to use both LAN and WAN ports on the device as part of your LAN.

You need to use WAN, not LAN to connect to your main router.

If you use LAN, it will bridge to the main router and you may have two DHCP servers. You cannot access GL router because it is transparent.

You should use the WAN port connecting to your main router and the Mini router will create a firewall. When you connect to the mini router, you will be in a subnet which is different from your main router’s network.

Just to confirm i have already disabled authoritative; it was one of the first settings i had disabled; beside it is writ “this is the only dhcp in the local network…” which I quoted earlier.

@alzhao I will take your advice to heart, thank you so much. I do see the option to disable bridging under advanced so that is optional on either port; How can I make the GL gui console non transparent to devices on the Asus ac68u Merlin router? I bought this little thing primarily as a wifi repeater for my Iphone; though I really am blown away with openwrt and its plethora of settings and I wish to explore it very much. I am inconvenienced by the fact I must either use my iphone or re set the lan cables each time I wish to enter the gui. And I am also just getting new to Merlin and fixing issues there so jumping back and fourth is very inconvenient. I used to be able to access two routers from my desktop but after upgrading to the Asus it doesn’t seem as simple; If necessary, I can configure static addresses on the lan pcs so there will be no dhcp autoconfig crossover; I’ve run into that quite a bit previously but im sure static addresses can fix that… even better would be everything working automatically without the necessity for this. I’m assuming disabling authoritative should hopefully address that.

There are settings in merlin which simplify connecting extra routers; i’ve done the following as seen in the image. Still cannot access the gui at the given ip. I’ll have to mess around with this a bit more. Static ip assigned to GL from merlin and GL resulted in successful connection to Asus router, however zero internet connectivity. Gotta iron this out.

I looked through your posts and fell this can be complicated. Don’t have time to try and cannot really help.