MT300N does not send internet traffic through openvpn tunnel

Hi, can anyone help? My MT300N V2s is in remote location, connects to my openvpn at home and everything looks fine. Client pc that is connected to the lan port of mt300N can access the internal lan at home, but the router does not send internet traffic through the vpn tunnel, only traffic to my home lan is sent through openvpn. Internet traffic is sent through the internet on the remote location. When I activate ‘Force vpn’ my client pc can only access my home lan, all internet traffic gives an error. E.g. when I ping google on my pc, I get this error:
PING ( 56 data bytes
92 bytes from ( Destination Port Unreachable
Vr HL TOS Len ID Flg off TTL Pro cks Src Dst
4 5 00 5400 4cde 0 0000 3f 01 a7da
If I ssh to the router, I can access the internet through the vpn tunnel:
root@GL-MT300N-V2:~# ping -I tun0
PING ( 56 data bytes
64 bytes from seq=0 ttl=55 time=82.022 ms
It looks like the routing is not done correctly, but I cannot figure out what is wrong…

Can you set up custom dns?

Dns is custom set to, does not help.

upgraded to 2.27 also does not help. MT300N can reach outside world through both wan and vpntunnel. Why does it still send traffic over regular wan?

fixed it. Putting “redirect-gateway def1” in the .ovpn makes the router send all traffic through the vpn connection. Everything works now :slight_smile:

thanks for sharing this information

Did you use “force vpn” option? That should do the work already.