MT300N - outdated Zerotier package

I have updated my MT300N-V2 to the latest firmware (3.102) and have updated the software packages but the only Zerotier package available is 2 years and 6 versions old (1.2.8-2). The current version is 1.4.6 and there are significant improvements since the 1.2 version.

I see on the openwrt package list that version 1.4.6 is available. Is there a way to install the most recent Zerotier version?

You can upgrade your plugin with the following commands.

opkg update 
opkg upgrade zerotier

Thanks for the help.

I did the above but after installing and update/upgrade, opkg list-installed shows that I am still running Zerotier version 1.2.8-2. I guess that is becuase it’s pulling the package from the Gl.inet repository and not the openwrt repository. Is there a way to install the zerotier package from the openwrt repository?

I tried installing with:

opkg install

but I get the error:

root@GL-MT300N-V2:~# opkg install
Collected errors:

I downloaded the updated zerotier package to the tmp folder on the router and tried installing but get:

Upgrading zerotier on root from 1.2.8-2 to 1.4.6-1…
Collected errors:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for zerotier:
  •  libstdcpp6
  • opkg_install_cmd: Cannot install package zerotier.
    root@GL-MT300N-V2:/tmp# opkg install libstdcpp6
    Unknown package ‘libstdcpp6’.
    Collected errors:
  • opkg_install_cmd: Cannot install package libstdcpp6.

You can set the software source in advanced settings.