MT300N-V2 3.025 - Issues with 6-in-4 tunnel 3.025

Hi everyone,

I’ve finally purchased an MT300Nv2 to replace my MT300A (which has magically gone missing for whatever reason.

I use an RFC4213 service through Hurricane Electric, as we have no native IPv6 available, and I do handle quite a bit of European technical support.

After configuring this tunnel to work like every other OpenWRT tunnel I’ve had, I see it is only binding IPv6 to the disabled public interface, and not passthrough onto my LAN.

network.wan6=interface
network.wan6.proto='6in4'
network.wan6.peeraddr='66.220.7.82'
network.wan6.ip6prefix='2001:x:1f19:6ae::/64'
network.wan6.tunnelid='x'
network.wan6.username='xx'
network.wan6.password='xx'
network.wan6.ip6addr='2001:x:1f18:6ae::2/64'
network.wan6.mtu='1480'

IPv6 works from router:

root@MT300N-V2:~# ping ipv6.google.com
PING ipv6.google.com (2607:f8b0:400f:806::200e): 56 data bytes
64 bytes from 2607:f8b0:400f:806::200e: seq=0 ttl=52 time=94.455 ms
64 bytes from 2607:f8b0:400f:806::200e: seq=1 ttl=52 time=92.980 ms
64 bytes from 2607:f8b0:400f:806::200e: seq=2 ttl=52 time=93.422 ms
64 bytes from 2607:f8b0:400f:806::200e: seq=3 ttl=52 time=92.957 ms

It appears to be assigning my routed subnet to the disabled guest subnetwork only (ifstats wan6)

        "ipv6-prefix": [
                {
                        "address": "2001:470:1f19:6ae::",
                        "mask": 64,
                        "class": "wan6",
                        "assigned": {
                                "guest": {
                                        "address": "2001:470:1f19:6ae::",
                                        "mask": 64
                                }
                        }
                }
        ],

I want the router to vend my /64 as normal to any clients which will accept it natively, and for whatever reason, this is the first I’ve had which is behaving like this.

As a but I just noticed- my non-public WiFi interface works, but claims it’s not associated.

SSID: GL-MT300N-V2-673
Mode: Master
Wireless is not associated

GL-MT300N-V2-673-Guest
Mode: Master
Wireless is disabled

We are doing some ipv6 development work, but there is no 6in4 support.

Hi.

You provide the 6in4 package, and the only issue appears to be with both it defaulting to the guest network, and that LuCI doesn’t quite get the interface information correctly.

I’d be happy to remove the public interface if it will make things work correctly, but I also don’t want to break things, or drop back to stock OpenWRT.

Thanks.

I gave up and went back to my WNDR3800 because I don’t have time to further address this. I’ll keep it for mobile use, but the lack of functioning tunnel for the 6in4 is still a burden for me, since I can technically get a VAR11N to do the same thing despite less RAM and an older version of OpenWRT.