MT300n-v2 limited OPENWRT support?


#1

I’m trying to play around with OPENWRT on my Mt300n-v2, but it seems like the GL iNet shell prevents it from working 100%. Things that go wrong are:

  • I can’t set channel parameters in the wireless tab, like channel, channel width etc. Also when I change the config file it doesn’t react
  • I have OPENVPN configured through the GL iNet interface, but it doesn’t show in Luci
  • The wireless interface show as not available but are working correctly.

What would be the best way forward? Is there a way to disable the shell, or should I move to the clean firmware version?


#2

You have 2 options. One is to configure everything that the GL UI lets you, and then don’t touch those related things in Luci. Two is to just use the “clean” firmware version of the firmware, that is pure OpenWRT.

The issue is that the GL UI is changing things in the background, writing to configuration files directly. Luci is not seeing those changes, and will mess up configuration if you try to change conflicting settings. Generally the GL UI is much better than Luci for the settings it does have, so i would recommend you do just that, and if you need more advanced things, change those in Luci.


#3

Thanks for the quick reply!

I’m afraid that the thinks I want to try with the router go beyond the possibilities of the GL gui. I will save my current configuration in case I want to get back…


#4

Yeah if you want to do more advanced things, better use OpenWRT clean firmware. You will need to configure everything manually though, but there are guides online for all things like openvpn etc.


#5

Oké.
Don’t get me wrong though, I was impressed with what already was possible with the standard GUI: way more than expected. I just want to play around with OPENWRT and Linux possibilities…

Best regards,
Andy.


#6

Oké, messed around with openwrt clean, which offered some new challenges (not able to change wifi settings, not able to join network). Will revisit this later when I’ve got some more time…

However, tried to get back to the stock ‘v1’ version 2.271 firmware didn’t give me the GL iNet GUI, but just the reroute page (2 second page). The 192.168.8.1/html failed to open… Tried as well the standard upload as the uboot method.
Any clue on what could go wrong here?

Addition:
Solved it! Although don’t understand it. Once I try to open the /html page in a incognito page the configuration page is opening correctly. Refreshing in the standard browser page didn’t solve it…


#7

You need to use Shift+F5 to clear the cache. Or you can go to browser settings to clear the cache of 192.168.8.1


#8

Thanks, will remember that.

Would have been good if that had been stated somewhere. After 5 re-flashes I discovered it…