MT300N-V2 not auto connecting to networks in repeater mode

Greetings. I bought the Mango in order to have it connect to 2 networks, and be able to switch between them automatically when one is no longer available. I searched the forums and noticed a few users about 5 years ago had the same issues that I am going through.

Basically I have the router in my truck, and when started, I want it to boot up and connect to my home wifi saved network. Once I pull away from home and lose my home wifi connection, I would like the router to automatically go through the saved network list and try connecting to the next saved network (my phone hotspot).

I thought this use case would work, as under the repeater options, auto scan and re-connect is enabled. Am I mis-understanding what the auto scan and re-connect option is supposed to do? And of course, if I log in and manually select a network and click Join, it connects fine.

One user commented that the non-V2 version of the MT300N does indeed work the way I want it to work for my scenario. Am I doing something wrong, or is this still a bug that can be fixed with an update to make it work like the MT300N?

Any help is appreciated. Thanks!

I just tried a wee experiment with my Mango by connecting it to another hotspot. When I turned off the hotspot, the Mango immediately connected with the original wifi signal. So working fine. 3.215b3

To be clear, this is in router mode, not repeater mode (although connecting to a wifi signal in both cases in the GUI is referred to as “repeater”.

Weird. Mine is also in Router mode under Network Mode settings. I’m on 3.212. I’ll give the 3.215b3 a try. Thanks.

It should auto scan and connect. Unless it really tried hard but failed, then gave up. These info will be in the log.

So when met such problem, get the log.

We use one at work to bypass the crapply configured firewall for quick bot of SIP testing over wifi hotspot on a mobile (its easier than the telephone call).

Each time you have to find the network, and it will not reconnect.
I think this is because there is a “free” network with a fairly pweful transmit power that it wants to talk to instead (actually it may even be ours), ovbvioulsy we have never been to landing page for it.

Any open wifi where you are trying?


So with the updated firmware, my home wifi will now auto connect on boot, or when it is in the area. Winning half the battle here :slight_smile: Back to the phone… iPhone XS Max, running iOS 15.6.1. So I have my hotspot saved in the network list, but like I said, it will never auto connect, and still doesn’t even with 3.215b3.

I also notice that when I do a manual scan, my hotspot doesn’t always show up. Its rather random when it decides to reveal its SSID. Where exactly can I find the logs? I’ll take a look and see what is happening .

Reasonable assumption. You might try going into your saved networks, and if you can find that wifi connection, set it to not reconnect.

If the Mango is in router mode, when it connects to a wifi signal I think it resets the wifi connection for WISP mode but might get sidetracked. More frequently I find that the laptop I’m using to connect to the Mango goes off to a different signal in the meantime, and I have an unchanging Mango screen that doesn’t reflect that the connection has been made. If I then reconnect the laptop to the Mango, the screen shows a connection.

1 Like

To get the log, ssh to the router and use command logread to get the log.

Another update. In my previous post I said that my iPhone SSID would randomly show up while trying to find it via Scan or connect to it. Well, I don’t believe it, but it isn’t random. I did some more testing and figured out that the Mango can only see the iPhone SSID (brace yourself), whenever the iPhone is on the Settings>Personal Hotspot screen.

Sounds made up, but I was able to recreate this over and over once I figured it out. Not on the Personal Hotspot screen? I cannot find the hotspot via scan and it won’t connect even if I manually join. On that specific iPhone settings screen? Mango will find and automatically connect to the hotspot.

I am at a loss for words. I don’t even believe me.

Iphone Hotspot, can work on 2.4G or 5G.

So when you must choose “Maximise Compatibility”. Then it will work in 2.4G.

iphone hotspot may just disable itself if you do not use. Maybe this is another reason.

I recollect my Pixel 6a (Android) has a setting for this, something like “disable hotspot if no connected clients”.

EDIT: Yes, under hotspot settings there is “Turn off hotspot automatically if no connected clients”. Is there something similar for your iPhone?

1 Like