MT300N-V2 OpenVPN ForceVPN IP leak


In using the MT300N-V2’ s OpenVPN “Force VPN” (No Internet if VPN is not connected) feature, if the VPN login process gets stuck in the “connecting” status (if there is an issue with the VPN login), then the router will still pass Internet traffic through it as if it was in the “connected” status, resulting in IP leaks. Is there anyway to consider the “OpenVPN is: connecting” status the same the “OpenVPN is: not started” status, so no Internet traffic passes through?


Additional: “Force VPN” is misunderstanding. That should be replaced on firmware by “VPN only” or like this exact describtion.

as far as I know this should work. Did you try setting up other things?

Which firmware version are you using?

Thanks for the quick reply!

I didn’t setup anything else with OpenVPN, just added the .ovpn file and password. I tried to replicate this issue by reloading (or “applying”) the .ovpn config file, and tried to access Internet content via a browser while it was in “connecting” status, and it seemed to block traffic as it was processing the login steps. So it looks like it works there. But I have seen this issue when the status hangs on the “connecting” step, and can’t get out of it unless you manually reset/apply the .ovpn config file.

I am using the 2.271 firmware.