MT300N-V2 Samba Package is too old?

Hi Dude,

I’m configuring my portable router as windows pxe boot server, the idea is to install windows PE lite touch from the network (Usualy done by windows deployment server).

However i got stuck because the SMB v1 is no longer supported by windows 10 build 1709.

Is it possible for GL Inet team to update samba package to version 4, the current installed is 3.6 and not support SMB3 protocol.

root@GL-MT300N-V2:~# opkg list | grep samba36-server
samba36-server - 3.6.25-6 - The Samba software suite is a collection of programs that implements the SMB protocol for UNIX systems, allowing you to serve files and printers to Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred to as the LanManager or Netbios protocol.

Hardware firmware is 2.271

Will check on windows 10

Any good news zhao? Fyi it’also happen on the latest windows 10 build number 1803

Dear Dimz,
I checked the MT300N-V2 firmware 2.27 on Windows 10 (version 1803) for SMB use, and here is a snapshot for your information.


Now follow this guide:

And you will have the same issue as @Dimz

@Johnex, @Dimz,
Have you tried to select your USB drive folder?
Generally, Network drive in Windows10 requires you to select a certain folder for sharing.

Well i just access it using windows => run => ip address which normally in my other sharing folder(hosted in windows machine) is working properly.

I will test your suggestion and let you know the result by this night.

Meanwhile can you try to access the share folder using my step:

  1. Click windows start icon
  2. Type run
  3. In the run text box type \

**Additional information, my flashdisk was formated using ntfs and i mount it using this command

mount -t ntfs-3g “/dev/sda1” “Mount location”

BTW thanks for your response.

@Dimz I tried your step Run=>\ and it works properly. Just remind 2 things:

  1. if you plug-in USB drive to our router, it shall mount automatically.
  2. Have you tried directly plug-in your USB drive into PC usb port for a testing?

I changed some fstab mount setting based on this PXE configuration guide here [OpenWrt Wiki] PXE-Boot network boot server, perhaps it break some default mount configuration.
After i followed it my usb flashdisk still mounted automatically but in readonly mode that’s why i need to mount it manually.

Will try to reset the router and let you know the result tonight.

The router default setting is read-only, you can change the writable authority and share on WAN both in the web management UI:

You’re correct, no issue on both windows 10 1709 and 1803, it seems our domain admin configured some SMB policy in the domain and effected my office laptop, for what i remember they change the SMB to version 3 (not sure) from the group policy for to block wannacry ransomware spread.

It will be good for GL.Inet team to update the SMB package if it’s possible so it will be support SMBv3, but at this moment there’s no issue to implement the windows deployment over the network.

You may close this thread, i owe you a beer. thanks a bunch

1 Like