MT300N v2 WDS question


#1

Hi,
I just got my mt300n-v2 and it meant to replace my old TL-WR703N.
My main router is TP-Link and I enabled WDS on it.

The use of the mtn300n is to provide wired network for few devices (I’ve 5 port network switch) from my main wireless network and also extend the wifi of the main router.
It’s all working but I want the wifi network to have the same name as my main network.
When I change the name of the network to be the same, my wireless devices can’t connect to it…
When I connect to the mt300n default wifi without changing it I get an IP from my main router and it’s working fine.

Any way to make it work?

Thanks!

P.S.
I tried the relayd option but it didn’t work well.


#2

Can you confirm that the mt300n has its DHCP off, and that the you specified the gateway as the main router, and that its dns is properly configured?


#3

I did it the simple way.
Didn’t got into Luci since it a little bit different from what I know.
What interface to check?


#4

Even if you setup using the GL interface, I don’t think you can check what I mentioned without going into the luci configuration. Assuming you know how to get into luci (let me know if not), then…

Network->Interface, edit the LAN.

Check IPv4 gateway
Check Use custom DNS servers
Make sure “Ignore interface” is checked.


#5

Ok, so I don’t have a gateway on LAN but Ignore interface is checked.
Why do you think it matters?
Cause it looks like it happens only when the name of the wireless network is the same as my main network name…


#6

A couple more questions.

Have you done a hard reset of the m300 after you tried your relayd to make sure all of the settings are cleared?

Also, when you say

When I change the name of the network to be the same, my wireless devices can’t connect to it…

does that mean your devices literally can not connect to the SSID, or that if they connect, but cannot connect to the Internet? Can you ping other devices in your network?

Specifying a gateway is a routing issue. Let’s get you working, then we can get to your why questions.


#7

Ok, so I took a step further and I installed clean OpenWRT image without the GL UI.
Now I’ve relayd kind of working.
WWAN is the client connected to my main radio.
WAN is the access point of the MTN300N.
LAN is connected to the pc via cable.
STABRIDGE connect LAN,WAN and WWAN together.
It’s working Ok now.
I had one time that I had to reboot the MTN300N cause I couldn’t get to any of the devices in the network (although I had internet connection).
I hope it’ll keep working…


#8

Hope it continues to work. If not, come back and we’ll get you sorted.


#9

Thanks.
I actually have instable wifi.
Couldn’t find why…

Could you help me with this?

This is the log:

Sun Dec  2 22:53:19 2018 daemon.notice netifd: Network device 'wlan0' link is down
Sun Dec  2 22:53:19 2018 daemon.notice netifd: Interface 'wwan' has link connectivity loss
Sun Dec  2 22:53:19 2018 daemon.notice netifd: wwan (2709): udhcpc: received SIGTERM
Sun Dec  2 22:53:20 2018 daemon.notice netifd: Network device 'wlan0-1' link is down
Sun Dec  2 22:53:20 2018 kern.info kernel: [ 1697.255472] br-wan: port 2(wlan0-1) entered disabled state
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.757477] wlan0: authenticate with XX:XX:XX:XX:XX:XX
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.784694] wlan0: send auth to XX:XX:XX:XX:XX:XX (try 1/3)
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.793489] wlan0: authenticated
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.805499] wlan0: associate with XX:XX:XX:XX:XX:XX (try 1/3)
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.937395] wlan0: RX AssocResp from XX:XX:XX:XX:XX:XX (capab=0x31 status=0 aid=3)
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1697.945299] wlan0: associated
Sun Dec  2 22:53:21 2018 daemon.notice netifd: Network device 'wlan0' link is up
Sun Dec  2 22:53:21 2018 daemon.notice netifd: Interface 'wwan' has link connectivity
Sun Dec  2 22:53:21 2018 daemon.notice netifd: Interface 'wwan' is setting up now
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1698.079083] br-wan: port 2(wlan0-1) entered blocking state
Sun Dec  2 22:53:21 2018 kern.info kernel: [ 1698.084665] br-wan: port 2(wlan0-1) entered forwarding state
Sun Dec  2 22:53:21 2018 daemon.notice netifd: Network device 'wlan0-1' link is up
Sun Dec  2 22:53:21 2018 daemon.info dnsmasq[2214]: read /etc/hosts - 4 addresses
Sun Dec  2 22:53:21 2018 daemon.info dnsmasq[2214]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Sun Dec  2 22:53:21 2018 daemon.notice netifd: wwan (4435): udhcpc: started, v1.28.3
Sun Dec  2 22:53:21 2018 daemon.notice netifd: wwan (4435): udhcpc: sending discover
Sun Dec  2 22:53:24 2018 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED XX:XX:XX:XX:XX:XX
Sun Dec  2 22:53:24 2018 daemon.notice hostapd: wlan0-1: AP-STA-DISCONNECTED XX:XX:XX:XX:XX:XX
Sun Dec  2 22:53:24 2018 daemon.notice netifd: wwan (4435): udhcpc: sending discover
Sun Dec  2 22:53:25 2018 daemon.notice netifd: wwan (4435): udhcpc: sending select for 10.0.0.14
Sun Dec  2 22:53:25 2018 daemon.notice netifd: wwan (4435): udhcpc: lease of 10.0.0.14 obtained, lease time 7200
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: reading /tmp/resolv.conf.auto
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain test
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain onion
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain localhost
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain local
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain invalid
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain bind
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain lan
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using nameserver 10.0.0.138#53
Sun Dec  2 22:53:25 2018 daemon.notice netifd: Interface 'wwan' is now up
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: reading /tmp/resolv.conf.auto
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain test
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain onion
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain localhost
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain local
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain invalid
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain bind
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using local addresses only for domain lan
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using nameserver 10.0.0.138#53
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using nameserver 1.1.1.1#53
Sun Dec  2 22:53:25 2018 daemon.info dnsmasq[2214]: using nameserver 1.0.0.1#53
Sun Dec  2 22:53:27 2018 daemon.info dnsmasq[2214]: read /etc/hosts - 4 addresses
Sun Dec  2 22:53:27 2018 daemon.info dnsmasq[2214]: read /tmp/hosts/dhcp.cfg01411c - 0 addresses
Sun Dec  2 22:53:46 2018 daemon.info hostapd: wlan0-1: STA XX:XX:XX:XX:XX:XX IEEE 802.11: authenticated
Sun Dec  2 22:53:46 2018 daemon.info hostapd: wlan0-1: STA XX:XX:XX:XX:XX:XX IEEE 802.11: associated (aid 1)
Sun Dec  2 22:53:46 2018 daemon.notice hostapd: wlan0-1: AP-STA-CONNECTED XX:XX:XX:XX:XX:XX
Sun Dec  2 22:53:46 2018 daemon.info hostapd: wlan0-1: STA XX:XX:XX:XX:XX:XX WPA: pairwise key handshake completed (RSN)

#10

Sure. First, let’s confirm what your goal is. Hand sketch and upload your situation (current and ideal). Please re-read my questions above in order to guide your response. I think you want a WDS repeater.


#11

So this is my ideal goal.

I think I can do it with WDS or without it.
The only issue is that my main router can’t be WDS access point AFAIK.
It asks for WDS MAC address, but I might be wrong.

Currently using relayd but it looks like wlan0 is crashing…


#12

Thanks, that it’s very helpful.

I assume both the wired and wireless devices connected to the mt300 each want access to the internet. Do they need access to any device not connected to the mt300 (besides the main router)? If not, than a WISP repeater is all you need the mt300 to do. Super easy.


#13

The open wireless driver for MT7628 is instable, so MT300N-V2 uses closed wireless driver. For your topology diagram, you can set it to WISP instead of WDS mode.


#14

@klaberte
They need access to one PC that’s connected directly to the main router via wifi.

@kyson-lok
I tried WISP before I flashed the clean OpenWRT image.
Maybe you can instruct me how to do it the right way and I’ll flash the GL firmware back and try.


#15

You can flash the GL firmware back, and follow this tutorial to set WISP up. https://docs.gl-inet.com/en/2/setup/internet_setting/#wisp


#16

I can’t use WISP because it’s creating different subnet which will limit my access to other devices on my network.


#17

If you use v2.271 firmware, you can configure it to WISP at first, and then configure switch function to relayd, so you can use it as router or bridge by slipping switch button.


#18

How can I configure the switch for relayd?


#19

Sorry for my mistake, v2.0 firmware doesn’t implement relayd for MT300N-V2, but you can configure it to WDS mode. Please refer to https://docs.gl-inet.com/en/2/setup/internet_setting/#wds


#20

For MT300N-V2, the WDS works with any routers. Be sure to input a correct LAN IP. Otherwise WDS in MT300N-V2 doesn’t work properly.

For example, if your main router subnet is 192.168.1.1/24, then input an IP which is 192.168.1.22 which is not used by any other devices.